diff mbox series

[bug#40510] gnu: Add wolf-shaper.

Message ID 8f1ab59c54c7341189456a2d470b3e14b3a5a5ef.camel@zrythm.org
State Accepted
Headers show
Series [bug#40510] gnu: Add wolf-shaper. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Alexandros Theodotou April 8, 2020, 4:37 p.m. UTC
Reattaching wolf-spectrum (forgot to change the homepage).
diff mbox series

Patch

From 0b0f8211055488a3f22fdc1114d6b43cfa983d33 Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Wed, 8 Apr 2020 17:30:45 +0100
Subject: [PATCH 2/2] gnu: Add wolf-spectrum.

* gnu/packages/music.scm (wolf-spectrum): New variable.
---
 gnu/packages/music.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 1f9b1e543b..c0f4e277cb 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5479,3 +5479,26 @@  plugin and a standalone JACK application.")
 It is provided as an LV2 plugin and as a standalone Jack application.")
     (home-page "https://pdesaulniers.github.io/wolf-shaper/")
     (license license:gpl3)))
+
+(define-public wolf-spectrum
+  (package
+    (inherit wolf-shaper)
+    (name "wolf-spectrum")
+    (version "1.0.0")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/pdesaulniers/wolf-spectrum")
+               (commit (string-append "v" version))
+               ;; Bundles a specific commit of the DISTRHO plugin framework.
+               (recursive? #t)))
+        (file-name (git-file-name name version))
+        (sha256
+          (base32
+            "17db1jlj7vb1xyvkdhhrsvdbwb7jqw6i4168cdvlj3yvn2ra8gpm"))))
+    (synopsis "2D spectrogram plugin")
+    (description "Wolf Spectrum is a real-time 2D spectrogram plugin.
+It is provided as an LV2 plugin and as a standalone Jack application.")
+    (home-page "https://github.com/pdesaulniers/wolf-spectrum")
+    (license license:gpl3)))
-- 
2.26.0