diff mbox series

[bug#56140,v3,1/2] gnu: Add optional-lite.

Message ID 8f0_XMg_VHnoitWfCRC59AlneNq7vei3tvYz5Z6DQbQJy9hys7ZEWiUYJn9OQGJMvvrx6EO14lCeHAzUFqCotDxwXf26AutrCh-OOd8sE2Q=@proton.me
State New
Headers show
Series [bug#56140,v3,1/2] gnu: Add optional-lite. | expand

Commit Message

Sughosha June 16, 2023, 2:06 p.m. UTC
* gnu/packages/music.scm (optional-lite): New variable.
---
 gnu/packages/cpp.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 365b15a3b9..8f5d305a26 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -2068,6 +2068,29 @@  (define-public bloomberg-bde
       (home-page "https://github.com/bloomberg/bde")
       (license license:asl2.0))))
 
+(define-public optional-lite
+  (package
+    (name "optional-lite")
+    (version "3.5.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/martinmoene/optional-lite")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+                (base32
+                 "0jpsm94kp1504yk9s2km86zv8xrszz30qanmhz2ljmvsdblz2l47"))))
+    (build-system cmake-build-system)
+    (home-page "https://github.com/martinmoene/optional-lite")
+    (synopsis "Nullable object for C++98, C++11 and later")
+    (description
+     "optional lite is a single-file header-only library to represent optional
+(nullable) objects and pass them by value. The library aims to provide a
+C++17-like optional for use with C++98 and later. If available, std::optional
+is used.")
+    (license license:boost1.0)))
+
 (define-public gulrak-filesystem
   (package
     (name "gulrak-filesystem")