[bug#74495,04/16] gnu: Add go-github-com-kylelemons-godebug-pretty.

Message ID 8eaada52036915fa34de556f294b05b5e063d1b2.1732386154.git.poptsov.artyom@gmail.com
State New
Headers
Series gnu: Add go-github-com-noahgorstein-jqp. |

Commit Message

Artyom V. Poptsov Nov. 23, 2024, 6:28 p.m. UTC
  * gnu/packages/golang.scm (go-github-com-kylelemons-godebug-pretty): New variable.

Change-Id: Icd7d5fd70cf56d1ca74e9a2cfb929a3344128ba7
---
 gnu/packages/golang.scm | 8 ++++++++
 1 file changed, 8 insertions(+)
  

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 8dd8350847..f4a14cc427 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -4722,6 +4722,14 @@  (define-public go-github-com-kylelemons-godebug
 representation suitable for computing diffs.")
     (license license:asl2.0)))
 
+(define-public go-github-com-kylelemons-godebug-pretty
+  (package
+    (inherit go-github-com-kylelemons-godebug)
+    (name "go-github-com-kylelemons-godebug-pretty")
+    (arguments
+     '(#:import-path "github.com/kylelemons/godebug/pretty"
+       #:unpack-path "github.com/kylelemons/godebug"))))
+
 (define-public go-github-com-kr-text
   (package
     (name "go-github-com-kr-text")