diff mbox series

[bug#74497,01/46] gnu: Add cdf.

Message ID 8e6ee652dc9638f75946892fbac0b172b5c7f839.1732384228.git.sharlatanus@gmail.com
State New
Headers show
Series Astro update 2024/11. | expand

Commit Message

Sharlatan Hellseher Nov. 23, 2024, 7:50 p.m. UTC
* gnu/packages/astronomy.scm (cdf): New variable.

Change-Id: I596dd3d1050e9276009d7e19fd9e9d1514510230
---
 gnu/packages/astronomy.scm | 52 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 52 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 1afdcd15a9..fc34cb7c40 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -460,6 +460,58 @@  (define-public ccfits
     (license (license:non-copyleft "file://License.txt"
                                    "See License.txt in the distribution."))))
 
+(define-public cdf
+  (package
+    (name "cdf")
+    (version "3.9.1")
+    (source
+     (origin
+       (method url-fetch)
+       ;; The archive version is esoteric here, meanwhile it's mentioned as
+       ;; normal semantic version in documentation (eg. 39_1), update the URL
+       ;; URL accordingly.
+       (uri (string-append
+             "https://spdf.gsfc.nasa.gov/pub/software/cdf/dist/"
+             "cdf39_1/linux/cdf39_1-dist-cdf.tar.gz" ))
+       (sha256
+        (base32 "08k6yv6gb0abhqp7dfysll5dgqc7kqbcvyiq4winnilazp6n1n01"))))
+    (build-system gnu-build-system)
+    (arguments
+     (list
+      #:test-target "test"
+      #:make-flags
+      #~(list "CURSES=no"
+              "ENV=gnu"
+              "FORTRAN=no"
+              "OS=linux"
+              "SHARED=yes"
+              (string-append "INSTALLDIR=" #$output)
+              "all")
+      #:phases
+      #~(modify-phases %standard-phases
+          ;; no configure
+          (delete 'configure))))
+    (home-page "https://cdf.gsfc.nasa.gov/")
+    (synopsis "NASA's Common Data Format library and tools")
+    (description
+     "CDF or CDF Library is a scientific data management package which allows
+programmers and application developers to manage and manipulate scalar, vector,
+and multi-dimensional data arrays.
+
+The @acronym{CDF, Common Data Format} is a self-describing data abstraction for
+the storage and manipulation of multidimensional data in a platform- and
+discipline-independent fashion.
+
+This package provides library and binary utilities to manipulate CDF files.")
+    ;; This software may be copied or redistributed as long as it is not sold
+    ;; for profit, see <https://cdf.gsfc.nasa.gov/html/cdf_copyright.html>.
+    ;;
+    ;; There are no license agreements or costs involved in obtaining or using
+    ;; CDF, see <https://cdf.gsfc.nasa.gov/html/faq.html>.
+    (license (license:non-copyleft
+              "file://CDF_copyright.txt"
+              "See CDF_copyright.txt in the distribution."))))
+
 (define-public celestia
   (package
     (name "celestia")