diff mbox series

[bug#46075,liferea] : Update +

Message ID 8dddcdd2-30bd-effd-761f-147f36c5eb4d@raghavgururajan.name
State New
Headers show
Series [bug#46075,liferea] : Update + | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Raghav Gururajan Jan. 31, 2021, 8:19 p.m. UTC
Hi Efraim!

> That patch is some 62k lines. Is there something shorter that we can use
> that isn't a repackaging of HEAD?

Thanks for pushing the other 2 patches. Here is the revised 3rd patch.

Regards,
RG.
diff mbox series

Patch

From 2ba60cc44eb3a488c295bb654a3673d305dccf05 Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <rg@raghavgururajan.name>
Date: Sun, 31 Jan 2021 15:15:15 -0500
Subject: [PATCH 4/4] gnu: liferea: Update to 1.13.5.

* gnu/packages/patches/liferea-getfocus.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/syndication.scm (liferea) [version]: Modify.
[source]<origin>[sha256]: Modify.
[patches]: Add liferea-getfocus.patch.
---
 gnu/local.mk                                |   1 +
 gnu/packages/patches/liferea-getfocus.patch | 269 ++++++++++++++++++++
 gnu/packages/syndication.scm                |  10 +-
 3 files changed, 277 insertions(+), 3 deletions(-)
 create mode 100644 gnu/packages/patches/liferea-getfocus.patch

diff --git a/gnu/local.mk b/gnu/local.mk
index e93425f394..6679b6fb17 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1313,6 +1313,7 @@  dist_patch_DATA =						\
   %D%/packages/patches/lierolibre-newer-libconfig.patch		\
   %D%/packages/patches/lierolibre-remove-arch-warning.patch	\
   %D%/packages/patches/lierolibre-try-building-other-arch.patch	\
+  %D%/packages/patches/liferea-getfocus.patch                   \
   %D%/packages/patches/linbox-fix-pkgconfig.patch		\
   %D%/packages/patches/linkchecker-tests-require-network.patch	\
   %D%/packages/patches/linphoneqt-tabbutton.patch		\
diff --git a/gnu/packages/patches/liferea-getfocus.patch b/gnu/packages/patches/liferea-getfocus.patch
new file mode 100644
index 0000000000..aa756cd71f
--- /dev/null
+++ b/gnu/packages/patches/liferea-getfocus.patch
@@ -0,0 +1,269 @@ 
+From 250e4f00572404e60c92b7f348c25ee6b160ff6b Mon Sep 17 00:00:00 2001
+From: Lars Windolf <lars.windolf@gmx.de>
+Date: Thu, 14 Jan 2021 17:03:14 +0100
+Subject: [PATCH] Avoid scanning files in inst/. Fixes getfocus.py include.
+
+---
+ po/POTFILES.in | 189 ++++++++++++++++++++++++-------------------------
+ 1 file changed, 94 insertions(+), 95 deletions(-)
+
+diff --git a/po/POTFILES.in b/po/POTFILES.in
+index 8f8c52730..aac45eaa6 100644
+--- a/po/POTFILES.in
++++ b/po/POTFILES.in
+@@ -1,15 +1,12 @@
+ [encoding: UTF-8]
+-
+ # List of source files containing translatable strings.
+-
+ net.sourceforge.liferea.appdata.xml.in
+ net.sourceforge.liferea.desktop.in
+-xslt/feed.xml.in
+-xslt/source.xml.in
+-xslt/folder.xml.in
+-xslt/item.xml.in
+-xslt/newsbin.xml.in
+-xslt/vfolder.xml.in
++plugins/getfocus.py
++plugins/headerbar.py
++plugins/libnotify.py
++plugins/plugin-installer.py
++plugins/trayicon.py
+ src/browser.c
+ src/browser_history.c
+ src/comments.c
+@@ -31,10 +28,35 @@ src/favicon.c
+ src/favicon.h
+ src/feed.c
+ src/feed.h
+-src/feed_parser.c
+-src/feed_parser.h
+ src/feedlist.c
+ src/feedlist.h
++src/feed_parser.c
++src/feed_parser.h
++src/fl_sources/default_source.c
++src/fl_sources/default_source.h
++src/fl_sources/dummy_source.c
++src/fl_sources/dummy_source.h
++src/fl_sources/google_source.c
++src/fl_sources/google_source.h
++src/fl_sources/node_source.c
++src/fl_sources/node_source.h
++src/fl_sources/opml_source.c
++src/fl_sources/opml_source.h
++src/fl_sources/reedah_source.c
++src/fl_sources/reedah_source_feed.c
++src/fl_sources/reedah_source_feed_list.c
++src/fl_sources/reedah_source_feed_list.h
++src/fl_sources/reedah_source.h
++src/fl_sources/theoldreader_source.c
++src/fl_sources/theoldreader_source_feed.c
++src/fl_sources/theoldreader_source_feed_list.c
++src/fl_sources/theoldreader_source_feed_list.h
++src/fl_sources/theoldreader_source.h
++src/fl_sources/ttrss_source.c
++src/fl_sources/ttrss_source_feed.c
++src/fl_sources/ttrss_source_feed_list.c
++src/fl_sources/ttrss_source_feed_list.h
++src/fl_sources/ttrss_source.h
+ src/folder.c
+ src/folder.h
+ src/html.c
+@@ -45,10 +67,10 @@ src/item.c
+ src/item.h
+ src/item_history.c
+ src/item_history.h
+-src/item_loader.c
+-src/item_loader.h
+ src/itemlist.c
+ src/itemlist.h
++src/item_loader.c
++src/item_loader.h
+ src/itemset.c
+ src/itemset.h
+ src/liferea_application.c
+@@ -62,6 +84,30 @@ src/node.c
+ src/node.h
+ src/node_type.c
+ src/node_type.h
++src/parsers/atom10.c
++src/parsers/atom10.h
++src/parsers/html5_feed.c
++src/parsers/html5_feed.h
++src/parsers/ldjson_feed.c
++src/parsers/ldjson_feed.h
++src/parsers/ns_admin.c
++src/parsers/ns_admin.h
++src/parsers/ns_ag.c
++src/parsers/ns_ag.h
++src/parsers/ns_cC.c
++src/parsers/ns_cC.h
++src/parsers/ns_content.c
++src/parsers/ns_content.h
++src/parsers/ns_dc.c
++src/parsers/ns_dc.h
++src/parsers/ns_slash.c
++src/parsers/ns_slash.h
++src/parsers/ns_syn.c
++src/parsers/ns_syn.h
++src/parsers/rss_channel.c
++src/parsers/rss_channel.h
++src/parsers/rss_item.c
++src/parsers/rss_item.h
+ src/render.c
+ src/render.h
+ src/rule.c
+@@ -73,112 +119,59 @@ src/subscription.h
+ src/subscription_icon.c
+ src/subscription_icon.h
+ src/subscription_type.h
+-src/update.c
+-src/update.h
+-src/vfolder.c
+-src/vfolder.h
+-src/vfolder_loader.c
+-src/vfolder_loader.h
+-src/xml.c
+-src/xml.h
++src/ui/auth_dialog.c
++src/ui/auth_dialog.h
++src/ui/browser_tabs.c
++src/ui/browser_tabs.h
+ src/ui/enclosure_list_view.c
+ src/ui/enclosure_list_view.h
++src/ui/feed_list_view.c
++src/ui/feed_list_view.h
+ src/ui/icons.c
+ src/ui/icons.h
++src/ui/item_list_view.c
++src/ui/item_list_view.h
+ src/ui/itemview.c
+ src/ui/itemview.h
+-src/ui/liferea_shell.c
+-src/ui/liferea_shell.h
+-src/ui/rule_editor.c
+-src/ui/rule_editor.h
+-src/ui/search_dialog.c
+-src/ui/search_dialog.h
+-src/ui/search_folder_dialog.h
+-src/ui/search_folder_dialog.c
+-src/ui/auth_dialog.c
+-src/ui/auth_dialog.h
+ src/ui/liferea_dialog.c
+ src/ui/liferea_dialog.h
+-src/ui/ui_common.c
+-src/ui/ui_dnd.c
+-src/ui/ui_dnd.h
+-src/ui/feed_list_view.c
+-src/ui/feed_list_view.h
+-src/ui/ui_folder.c
+-src/ui/ui_folder.h
+ src/ui/liferea_htmlview.c
+ src/ui/liferea_htmlview.h
+-src/ui/item_list_view.c
+-src/ui/item_list_view.h
+ src/ui/liferea_shell.c
++src/ui/liferea_shell.c
++src/ui/liferea_shell.h
+ src/ui/liferea_shell.h
+ src/ui/popup_menu.c
+ src/ui/popup_menu.h
+ src/ui/preferences_dialog.c
+ src/ui/preferences_dialog.h
++src/ui/rule_editor.c
++src/ui/rule_editor.h
++src/ui/search_dialog.c
++src/ui/search_dialog.h
++src/ui/search_folder_dialog.c
++src/ui/search_folder_dialog.h
+ src/ui/subscription_dialog.c
+ src/ui/subscription_dialog.h
+-src/ui/browser_tabs.c
+-src/ui/browser_tabs.h
++src/ui/ui_common.c
++src/ui/ui_dnd.c
++src/ui/ui_dnd.h
++src/ui/ui_folder.c
++src/ui/ui_folder.h
+ src/ui/ui_update.c
+ src/ui/ui_update.h
+-src/parsers/atom10.c
+-src/parsers/atom10.h
+-src/parsers/html5_feed.c
+-src/parsers/html5_feed.h
+-src/parsers/ldjson_feed.c
+-src/parsers/ldjson_feed.h
+-src/parsers/ns_admin.c
+-src/parsers/ns_admin.h
+-src/parsers/ns_ag.c
+-src/parsers/ns_ag.h
+-src/parsers/ns_cC.c
+-src/parsers/ns_cC.h
+-src/parsers/ns_content.c
+-src/parsers/ns_content.h
+-src/parsers/ns_dc.c
+-src/parsers/ns_dc.h
+-src/parsers/ns_slash.c
+-src/parsers/ns_slash.h
+-src/parsers/ns_syn.c
+-src/parsers/ns_syn.h
+-src/parsers/rss_channel.c
+-src/parsers/rss_channel.h
+-src/parsers/rss_item.c
+-src/parsers/rss_item.h
+-src/fl_sources/default_source.c
+-src/fl_sources/default_source.h
+-src/fl_sources/dummy_source.c
+-src/fl_sources/dummy_source.h
+-src/fl_sources/google_source.c
+-src/fl_sources/google_source.h
+-src/fl_sources/opml_source.c
+-src/fl_sources/opml_source.h
+-src/fl_sources/node_source.c
+-src/fl_sources/node_source.h
+-src/fl_sources/reedah_source.c
+-src/fl_sources/reedah_source.h
+-src/fl_sources/reedah_source_feed.c
+-src/fl_sources/reedah_source_feed_list.c
+-src/fl_sources/reedah_source_feed_list.h
+-src/fl_sources/ttrss_source.c
+-src/fl_sources/ttrss_source.h
+-src/fl_sources/ttrss_source_feed.c
+-src/fl_sources/ttrss_source_feed_list.c
+-src/fl_sources/ttrss_source_feed_list.h
+-src/fl_sources/theoldreader_source.c
+-src/fl_sources/theoldreader_source.h
+-src/fl_sources/theoldreader_source_feed.c
+-src/fl_sources/theoldreader_source_feed_list.c
+-src/fl_sources/theoldreader_source_feed_list.h
+-src/webkit/webkit.c
++src/update.c
++src/update.h
++src/vfolder.c
++src/vfolder.h
++src/vfolder_loader.c
++src/vfolder_loader.h
+ src/webkit/liferea_web_view.c
+ src/webkit/web_extension/liferea_web_extension.c
+ src/webkit/web_extension/web_extension_main.c
+-plugins/headerbar.py
+-plugins/libnotify.py
+-plugins/plugin-installer.py
+-plugins/trayicon.py
++src/webkit/webkit.c
++src/xml.c
++src/xml.h
+ [type: gettext/glade]glade/about.ui
+ [type: gettext/glade]glade/auth.ui
+ [type: gettext/glade]glade/enclosure_handler.ui
+@@ -202,3 +195,9 @@ plugins/trayicon.py
+ [type: gettext/glade]glade/theoldreader_source.ui
+ [type: gettext/glade]glade/ttrss_source.ui
+ [type: gettext/glade]glade/update_monitor.ui
++xslt/feed.xml.in
++xslt/folder.xml.in
++xslt/item.xml.in
++xslt/newsbin.xml.in
++xslt/source.xml.in
++xslt/vfolder.xml.in
diff --git a/gnu/packages/syndication.scm b/gnu/packages/syndication.scm
index 0e33f99910..f5d40b2c96 100644
--- a/gnu/packages/syndication.scm
+++ b/gnu/packages/syndication.scm
@@ -184,7 +184,7 @@  file system, and many more features.")
 (define-public liferea
   (package
     (name "liferea")
-    (version "1.13.4")
+    (version "1.13.5")
     (source
      (origin
        (method git-fetch)
@@ -192,13 +192,17 @@  file system, and many more features.")
              (url "https://github.com/lwindolf/liferea/")
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
+       (patches
+        (search-patches
+         ;; To be removed in version 1.13.6.
+         "liferea-getfocus.patch"))
        (sha256
-        (base32 "1g9463bvswsm899j6dfhslcg6np70m5wq143mjicr24zy8d17bm7"))))
+        (base32 "0yz5k4shdw12pwyvyhwx0vicjickv2ljfhryhc9s886swiq8ssrs"))))
     (build-system glib-or-gtk-build-system)
     (arguments
      `(#:configure-flags
        (list
-         "--disable-static")
+        "--disable-static")
        #:phases
        (modify-phases %standard-phases
          (add-before 'configure 'prepare-build-environment
-- 
2.30.0