diff mbox series

[bug#54753] gnu: Add smtpmail

Message ID 8db52a33-c3d9-d88d-fba8-e987dc68962f@cock.li
State Accepted
Headers show
Series [bug#54753] gnu: Add smtpmail | expand

Commit Message

Justin Veilleux April 6, 2022, 5:17 p.m. UTC
Here is a patch to add smtpmail.

Cheers.
diff mbox series

Patch

From c1c1dea4834c47adf7269070831696f28ffb949d Mon Sep 17 00:00:00 2001
From: terramorpha <terramorpha@cock.li>
Date: Wed, 6 Apr 2022 13:11:52 -0400
Subject: [PATCH] gnu: Add smtpmail.

* gnu/packages/mail.scm (smtpmail): New variable.
---
 gnu/packages/mail.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 16569741a4..6dc8db526f 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -46,6 +46,7 @@ 
 ;;; Copyright © 2021 Morgan Smith <Morgan.J.Smith@outlook.com>
 ;;; Copyright © 2021 Philip McGrath <philip@philipmcgrath.com>
 ;;; Copyright © 2022 Andrew Tropin <andrew@trop.in>
+;;; Copyright © 2022 Justin Veilleux <terramorpha@cock.li>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -4597,3 +4598,25 @@  (define-public sendgmail
 all known forks, including support for non-@code{@@gmail.com} email
 addresses.")
       (license license:asl2.0))))
+
+(define-public smtpmail
+  (package
+    (name "smtpmail")
+    (version "0.4.5")
+    (source
+     (origin
+       (method url-fetch)
+       (uri
+        (string-append
+         "http://download.savannah.nongnu.org/releases/smtpmail/smtpmail-"
+         version
+         ".tar.gz"))
+       (sha256 (base32 "08ap2l2g2avkq2jx05jy993517vvapmypg7j5cwl8gvpq436gdh5"))))
+    (build-system gnu-build-system)
+    (home-page "https://www.nongnu.org/smtpmail/")
+    (synopsis "SMTP utility")
+    (description
+     "smtpmail is a little console-based tool for users who have no local
+mailserver on her machine. it enables these users to send their mail over a
+remote smtp server.")
+    (license license:gpl2)))
-- 
2.34.0