diff mbox series

[bug#36146,1/4] gnu: Add emacs-elfeed-org.

Message ID 8d96ed21-28f6-4768-8d07-803a5d38b62a@www.fastmail.com
State Accepted
Headers show
Series Add various Emacs packages | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Alex Griffin June 9, 2019, 2:09 p.m. UTC
This patch adds emacs-elfeed-org, an Emacs package that lets you manage your Elfeed subscriptions in Org-mode.
diff mbox series

Patch

From 3c58d376419f16f7362c5325ea5ffb7bfcf7e61f Mon Sep 17 00:00:00 2001
From: Alex Griffin <a@ajgrf.com>
Date: Sun, 9 Jun 2019 09:00:05 -0500
Subject: [PATCH 1/4] gnu: Add emacs-elfeed-org.

* gnu/packages/emacs-xyz.scm (emacs-elfeed-org): New variable.
---
 gnu/packages/emacs-xyz.scm | 32 +++++++++++++++++++++++++++++++-
 1 file changed, 31 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 7db46e81c5..c1283f1ffd 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -13,7 +13,7 @@ 
 ;;; Copyright © 2016 Matthew Jordan <matthewjordandevops@yandex.com>
 ;;; Copyright © 2016, 2017 Roel Janssen <roel@gnu.org>
 ;;; Copyright © 2016, 2017 ng0 <ng0@n0.is>
-;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
+;;; Copyright © 2016, 2019 Alex Griffin <a@ajgrf.com>
 ;;; Copyright © 2016, 2017, 2018, 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
 ;;; Copyright © 2016, 2017, 2018 Alex Vong <alexvong1995@gmail.com>
 ;;; Copyright © 2016, 2017, 2018, 2019 Arun Isaac <arunisaac@systemreboot.net>
@@ -5209,6 +5209,36 @@  If you want to mark a folder manually as a project just create an empty
 and RSS, with a user interface inspired by notmuch.")
     (license license:gpl3+)))
 
+(define-public emacs-elfeed-org
+  (package
+    (name "emacs-elfeed-org")
+    (version "20181015.1100")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append
+               "https://melpa.org/packages/elfeed-org-"
+               version
+               ".el"))
+        (sha256
+          (base32
+            "1bawfxgijlfa4wska2znl69wfdzh53gh9arf180l71fhjlvablaw"))))
+    (build-system emacs-build-system)
+    (propagated-inputs
+      `(("emacs-elfeed" ,emacs-elfeed)
+        ("emacs-org" ,emacs-org)
+        ("emacs-dash" ,emacs-dash)
+        ("emacs-s" ,emacs-s)))
+    (home-page "https://github.com/remyhonig/elfeed-org")
+    (synopsis "Configure Elfeed with an Org-mode file")
+    (description
+      "@code{elfeed-org} lets you manage your Elfeed subscriptions
+in Org-mode.  Maintaining tags for all RSS feeds is cumbersome using
+the regular flat list, where there is no hierarchy and tag names are
+duplicated a lot.  Org-mode makes the book keeping of tags and feeds
+much easier.")
+    (license license:gpl3+)))
+
 (define-public emacs-el-x
   (package
     (name "emacs-el-x")
-- 
2.22.0