[bug#78434,2/3] gnu: python-sh: Update to 2.0.6

Message ID 8d75f27f24f95a69b82af4854fc921dbe72f60ef.1747280060.git.karl@hallsby.com
State New
Headers
Series Add sqlelf |

Commit Message

Karl Hallsby May 15, 2025, 3:43 a.m. UTC
  From: Raven Hallsby <karl@hallsby.com>

gnu/packages/python-xyz.scm (python-sh): Update to 2.0.6.

Change-Id: I0407fe9bbfef5b98ff6f7198e7fdd41e09fa94e1
---
 gnu/packages/python-xyz.scm | 18 +++++++-----------
 1 file changed, 7 insertions(+), 11 deletions(-)
  

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 66786466ba0..19b77c39d15 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4099,25 +4099,21 @@  (define-public python-pylsp-mypy
 (define-public python-sh
   (package
     (name "python-sh")
-    (version "1.14.2")
+    (version "2.0.6")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "sh" version))
        (sha256
         (base32
-         "03gyss1rhj4in7pgysg4q0hxp3230whinlpy1532ljs99lrx0ywx"))))
-    (build-system python-build-system)
+         "18bvpw02lzhlpsaqaf0kxybp0jb72c5iy1n0w9vwf0gj2grrhacv"))))
+    (build-system pyproject-build-system)
     (arguments
-     '(#:phases
-       (modify-phases %standard-phases
-         (replace 'check
-           (lambda _
-             ;; XXX: A Python 2 test fails when HOME=/homeless-shelter.
-             (setenv "HOME" "/tmp")
-             (invoke "python" "sh.py" "test"))))))
+     ;; Tests rely on python-tox, which introduces a cyclic dependency problem
+     ;; here.
+     '(#:tests? #f))
     (native-inputs
-     (list python-coverage))
+     (list python-coverage python-poetry-core))
     (home-page "https://github.com/amoffat/sh")
     (synopsis "Python subprocess replacement")
     (description "This package provides a replacement for Python's