diff mbox series

[bug#74233,rust-team,28/40] gnu: Add rust-gstreamer-allocators-sys-0.21.

Message ID 8d290f10ce4e0cd0d52bc436227bb9d6aeb453de.1730926145.git.goodoldpaul@autistici.org
State New
Headers show
Series [bug#74233,rust-team,01/40] gnu: Add rust-search-provider-0.8. | expand

Commit Message

Giacomo Leidi Nov. 6, 2024, 8:48 p.m. UTC
* gnu/packages/crates-gtk.scm (rust-gstreamer-allocators-sys-0.21): New variable.

Change-Id: Id2ef49791358b21fc9dd956f0fbeb41186526cf7
---
 gnu/packages/crates-gtk.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/crates-gtk.scm b/gnu/packages/crates-gtk.scm
index 5aa1d02cec..a320e8f4aa 100644
--- a/gnu/packages/crates-gtk.scm
+++ b/gnu/packages/crates-gtk.scm
@@ -2986,6 +2986,35 @@  (define-public rust-gstreamer-0.18
               ("rust-ron" ,rust-ron-0.7)
               ("rust-serde-json" ,rust-serde-json-1))))))
 
+(define-public rust-gstreamer-allocators-sys-0.21
+  (package
+    (name "rust-gstreamer-allocators-sys")
+    (version "0.21.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "gstreamer-allocators-sys" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "1brps4xpzigavifcwr6hs6368nilc4l03ivnv13fxb2svdw885f1"))))
+    (build-system cargo-build-system)
+    (arguments
+     ;; error: ?GstShmAllocatorClass? undeclared
+     `(#:tests? #f
+       #:cargo-inputs (("rust-glib-sys" ,rust-glib-sys-0.18)
+                       ("rust-gobject-sys" ,rust-gobject-sys-0.18)
+                       ("rust-gstreamer-sys" ,rust-gstreamer-sys-0.21)
+                       ("rust-libc" ,rust-libc-0.2)
+                       ("rust-system-deps" ,rust-system-deps-6))
+       #:cargo-development-inputs (("rust-shell-words" ,rust-shell-words-1)
+                                   ("rust-tempfile" ,rust-tempfile-3))))
+    (native-inputs (list pkg-config))
+    (inputs (list glib gstreamer gst-plugins-base))
+    (home-page "https://gstreamer.freedesktop.org")
+    (synopsis "FFI bindings to libgstallocators-1.0")
+    (description "This package provides FFI bindings to libgstallocators-1.0.")
+    (license license:expat)))
+
 (define-public rust-gstreamer-app-0.18
   (package
     (name "rust-gstreamer-app")