[bug#78430,1/2] gnu: screen: Use new package style.
Commit Message
* gnu/packages/screen.scm (screen)[arguments]: Change to list of G-Expressions.
---
gnu/packages/screen.scm | 13 +++++++------
1 file changed, 7 insertions(+), 6 deletions(-)
@@ -61,13 +61,14 @@ (define-public screen
(inputs
(list libxcrypt linux-pam ncurses perl))
(arguments
- `(#:configure-flags
+ (list
+ #:configure-flags
+ #~(list
;; GNU_SOURCE must be defined for mallocmock_reset() to be defined
- '("CFLAGS=-O2 -g -D_GNU_SOURCE=1"
-
- ;; By default, screen supports 16 colors, but we want 256 when
- ;; ~/.screenrc contains 'term xterm-256color'.
- "--enable-colors256")))
+ "CFLAGS=-O2 -g -D_GNU_SOURCE=1"
+ ;; By default, screen supports 16 colors, but we want 256 when
+ ;; ~/.screenrc contains 'term xterm-256color'.
+ "--enable-colors256")))
(home-page "https://www.gnu.org/software/screen/")
(synopsis "Full-screen window manager providing multiple terminals")
(description