[bug#77987,emacs-team,v3] gnu: emacs-ws-butler: Update to 1.3.
Commit Message
From: Cayetano Santos via Guix-patches via <guix-patches@gnu.org>
* gnu/packages/emacs-xyz.scm (emacs-ws-butler): Update to 1.3.
Change-Id: I5e50106efc32057f91bceff1a0b8fbbd2b1d7ef6
Signed-off-by: Cayetano Santos <csantosb@inventati.org>
---
[source]: Switch to git-fetch, as "tests" folder is absent from tar file.
Note that upstream github.com/lewang/ws-butler repository is obsolete since 0.7.
gnu/packages/emacs-xyz.scm | 39 ++++++++++++++++++++++----------------
1 file changed, 23 insertions(+), 16 deletions(-)
base-commit: 5e1ae1d2041255cb0da37071482f2af86ed84ba3
--
2.49.0
@@ -23147,24 +23147,31 @@ (define-public emacs-hercules
(license license:gpl3+)))
(define-public emacs-ws-butler
- (package
- (name "emacs-ws-butler")
- (version "1.1")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "https://elpa.nongnu.org/nongnu/ws-butler-" version
- ".tar"))
- (sha256
- (base32 "1vy7g2ryg1drcz9zpn011d36zcd9a5b5yny5hwpjrllqj5dg73jx"))))
- (build-system emacs-build-system)
- (home-page "https://elpa.nongnu.org/nongnu/ws-butler.html")
- (synopsis "Unobtrusively remove trailing whitespace")
- (description
- "ws-butler automatically trims trailing whitespace characters on save.
+ (let ((commit "9ee5a7657a22e836618813c2e2b64a548d27d2ff")
+ (revision "0"))
+ (package
+ (name "emacs-ws-butler")
+ (version (git-version "1.3" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.savannah.gnu.org/git/emacs/nongnu")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0ivpgib2bxv7x6cp04mj8crc1a60d7c77jcc59sj14scq4jqbmjb"))))
+ (build-system emacs-build-system)
+ (arguments (list #:test-command
+ #~(list "emacs" "--batch" "-L" "."
+ "-l" "tests/run-test.el")))
+ (home-page "https://elpa.nongnu.org/nongnu/ws-butler.html")
+ (synopsis "Unobtrusively remove trailing whitespace")
+ (description
+ "ws-butler automatically trims trailing whitespace characters on save.
In contrast with other whitespace cleanup solutions, only modified lines are
trimmed.")
- (license license:gpl3+)))
+ (license license:gpl3+))))
(define-public emacs-opencl-mode
(package