@@ -3381,6 +3381,28 @@ (define-public python-pairtools
")
(license license:expat)))
+(define-public python-rangehttpserver
+ (package
+ (name "python-rangehttpserver")
+ (version "1.4.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/danvk/RangeHTTPServer")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1dx533fsbq1mbz3by7qkm5bh2c253nwvm8214pqbwbfq07kqkwf2"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-coverage python-coveralls))
+ (native-inputs (list python-pytest))
+ (home-page "https://github.com/danvk/RangeHTTPServer")
+ (synopsis "SimpleHTTPServer with support for range requests")
+ (description
+ "This tool provides a simple HTTP server with support for Range requests.")
+ (license license:asl2.0)))
+
(define-public python-readpaf
(package
(name "python-readpaf")