diff mbox series

[bug#56299] gnu: Added breeze-gtk package.

Message ID 8c2173a9d5264c7b811927e64f6e8878f9ca013f.1656494787.git.samuel@nihil.ws
State Accepted
Headers show
Series [bug#56299] gnu: Added breeze-gtk package. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Samuel Matthiesen June 29, 2022, 9:26 a.m. UTC
I personally like my GTK and Qt programs to have a consistent look. I
noticed the GTK port of the Breeze theme was missing from the repos, so
this is adding it.

I am unsure about the licensing as their current repo mentions both the
LGPL 2.1 and BSD 3-clause. How should I set it properly? Is just LGPL
2.1 enough?

---
 gnu/packages/kde-plasma.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index 5621d8ea35..558efe0562 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -83,6 +83,31 @@  (define-public breeze
 the Plasma Desktop.  Breeze is the default theme for the KDE Plasma desktop.")
     (license license:gpl2+)))
 
+(define-public breeze-gtk
+  (package
+   (name "breeze-gtk")
+   (version "5.19.5")
+   (source (origin
+            (method url-fetch)
+            (uri (string-append "mirror://kde/stable/plasma/" version "/"
+                                name "-" version ".tar.xz"))
+            (sha256
+             (base32
+              "1j2nq9yw1ragmgwrz9f6ca4ifpi86qv1bbprdgd2qm2yh7vb44sj"))))
+   (build-system qt-build-system)
+   (arguments
+    `(#:phases
+      (modify-phases %standard-phases
+                     (delete 'check)))) ; Test phase not defined
+   (native-inputs
+    (list breeze extra-cmake-modules sassc python python-pycairo))
+   (home-page "https://invent.kde.org/plasma/breeze")
+   (synopsis "Default KDE Plasma theme (GTK+ port)")
+   (description "GTK+ port of the Breeze visual style for the Plasma Desktop.
+Breeze is the default theme for the KDE Plasma desktop.")
+   (license license:lgpl2.1)))
+
+
 (define-public kdecoration
   (package
     (name "kdecoration")