@@ -124,6 +124,7 @@
;;; Copyright © 2022 Artyom V. Poptsov <poptsov.artyom@gmail.com>
;;; Copyright © 2022 Paul A. Patience <paul@apatience.com>
;;; Copyright © 2022 Jean-Pierre De Jesus DIAZ <me@jeandudey.tech>
+;;; Copyright © 2022 Hilton Chain <hako@ultrarare.space>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -30203,3 +30204,26 @@ (define-public python-bsdiff4
binary diff utility. It also provides two command-line tools, @code{bsdiff4}
and @code{bspatch4}.")
(license license:bsd-2)))
+
+(define-public python-i3ipc
+ (package
+ (name "python-i3ipc")
+ (version "2.2.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/altdesktop/i3ipc-python")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "13bzs9dcv27czpnnbgz7a037lm8h991c8gk0qzzk5mq5yak24715"))))
+ (build-system python-build-system)
+ (arguments (list #:tests? #f)) ;FIXME: some tests are unable to run
+ (propagated-inputs (list python-xlib))
+ (home-page "https://github.com/altdesktop/i3ipc-python")
+ (synopsis "Python library for controlling i3 and Sway")
+ (description
+ "This package provides a Python library for controlling the i3 and Sway
+ window managers.")
+ (license license:bsd-3)))
* gnu/packages/python-xyz.scm (python-i3ipc): New variable. Signed-off-by: Hilton Chain <hako@ultrarare.space> --- gnu/packages/python-xyz.scm | 24 ++++++++++++++++++++++++ 1 file changed, 24 insertions(+) -- 2.36.1