diff mbox series

[bug#40510] gnu: Add wolf-shaper.

Message ID 8bac4beb758b4ab138718cd0f9211da1b69e6d63.camel@zrythm.org
State Accepted
Headers show
Series [bug#40510] gnu: Add wolf-shaper. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Alexandros Theodotou April 8, 2020, 4:31 p.m. UTC
Hi,

These patches add wolf-spectrum and wolf-shaper, 2 LV2 plugins.

Thanks,
Alex

Comments

Ludovic Courtès April 23, 2020, 9:59 p.m. UTC | #1
Hi Alexandros,

Alexandros Theodotou <alex@zrythm.org> skribis:

> From ff5050712a95e5dc84325ecceac50f84cd71ee14 Mon Sep 17 00:00:00 2001
> From: Alexandros Theodotou <alex@zrythm.org>
> Date: Wed, 8 Apr 2020 17:30:45 +0100
> Subject: [PATCH 2/2] gnu: Add wolf-spectrum.
>
> * gnu/packages/music.scm (wolf-spectrum): New variable.

[...]

> +    (synopsis "2D spectrogram plugin")
> +    (description "Wolf Spectrum is a real-time 2D spectrogram plugin.
> +It is provided as an LV2 plugin and as a standalone Jack application.")
> +    (home-page "https://pdesaulniers.github.io/wolf-shaper/")
> +    (license license:gpl3)))

[...]

> From 80dbd4b8eea3beea8eb312acdb56374f486bb9b7 Mon Sep 17 00:00:00 2001
> From: Alexandros Theodotou <alex@zrythm.org>
> Date: Wed, 8 Apr 2020 17:21:19 +0100
> Subject: [PATCH 1/2] gnu: Add wolf-shaper.
>
> * gnu/packages/music.scm (wolf-shaper): New variable.

[...]

> +    (synopsis "Waveshaper plugin")
> +    (description "Wolf Shaper is a waveshaper plugin with a graph editor.
> +It is provided as an LV2 plugin and as a standalone Jack application.")
> +    (home-page "https://pdesaulniers.github.io/wolf-shaper/")
> +    (license license:gpl3)))

Applied!

Two comments though:

  1. I believe the license is really ‘gpl3+’ because I don’t see
     anything saying “version 3 only”.  However, the situation is a bit
     confused because source files apparently still contain the ISC
     license header, perhaps an omission since the projects were
     apparently recently relicensed.

  2. The synopses could be improved: plugin for what? What application
     domain?  The descriptions could also be expounded a bit, and this
     would make ‘guix search’ happier.  :-)

Could you follow up on these two things?

Thanks,
Ludo’.
diff mbox series

Patch

From 80dbd4b8eea3beea8eb312acdb56374f486bb9b7 Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Wed, 8 Apr 2020 17:21:19 +0100
Subject: [PATCH 1/2] gnu: Add wolf-shaper.

* gnu/packages/music.scm (wolf-shaper): New variable.
---
 gnu/packages/music.scm | 57 ++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 57 insertions(+)

diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 5257d9463a..1f9b1e543b 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5422,3 +5422,60 @@  plugin and a standalone JACK application.")
   offers an LV2 version ported by moddevices.")
       (home-page "http://tap-plugins.sourceforge.net/")
       (license license:gpl2))))
+
+(define-public wolf-shaper
+  (package
+    (name "wolf-shaper")
+    (version "0.1.7")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/pdesaulniers/wolf-shaper.git")
+               (commit (string-append "v" version))
+               ;; Bundles a specific commit of the DISTRHO plugin framework.
+               (recursive? #t)))
+        (file-name (git-file-name name version))
+        (sha256
+          (base32
+            "0lllgcbnnh1m95bp29hh17x170hl7170zizjrvy892qfkn36830d"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:tests? #f                      ; no check target
+       #:make-flags (list "CC=gcc")
+       #:phases
+       (modify-phases %standard-phases
+         (delete 'configure)            ;no configure target
+         (replace 'install              ;no install target
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let* ((out (assoc-ref outputs "out"))
+                    (bin (string-append out "/bin"))
+                    (lv2 (string-append out "/lib/lv2")))
+               ;; Install LV2.
+               (for-each
+                (lambda (file)
+                  (copy-recursively file
+                                    (string-append lv2 "/" (basename file))))
+                (find-files "bin" "\\.lv2$" #:directories? #t))
+               ;; Install executables.
+               (for-each
+                 (lambda (file)
+                   (install-file file bin))
+                 (find-files "bin"
+                             (lambda (name stat)
+                               (and
+                                 (equal? (dirname name) "bin")
+                                 (not (string-suffix? ".so" name))
+                                 (not (string-suffix? ".lv2" name))))))
+               #t))))))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (inputs
+      `(("jack", jack-1)
+        ("lv2", lv2)
+        ("mesa", mesa)))
+    (synopsis "Waveshaper plugin")
+    (description "Wolf Shaper is a waveshaper plugin with a graph editor.
+It is provided as an LV2 plugin and as a standalone Jack application.")
+    (home-page "https://pdesaulniers.github.io/wolf-shaper/")
+    (license license:gpl3)))
-- 
2.26.0