diff mbox series

[bug#73995] gnu: Add go-github-com-caarlos0-env.

Message ID 8ba3c9c4c81f71bb9f44064a191aaf884ed6a190.1729803056.git.poptsov.artyom@gmail.com
State New
Headers show
Series [bug#73995] gnu: Add go-github-com-caarlos0-env. | expand

Commit Message

Artyom V. Poptsov Oct. 24, 2024, 8:50 p.m. UTC
* gnu/packages/golang-xyz.scm (go-github-com-caarlos0-env): New variable.

Change-Id: If15faf6ebae7c94204b816a9d784e6b28d70be2e
---
 gnu/packages/golang-xyz.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)


base-commit: 2394a7f5fbf60dd6adc0a870366adb57166b6d8b

Comments

Sharlatan Hellseher Oct. 26, 2024, 10:08 p.m. UTC | #1
Hi,

Thanks for packaging this, it's quite useful project in Go ecosystem
and it's indeed small!

Patch looks good for me, license is correct and only one mentioned.

Feel free to merge!

P.S.
It's quite a waste of efforts to package individual Golang libraries
without any final purpose, say pack "caddy -
<https://github.com/caddyserver/caddy>" or unbundle N++ from Kubo ;-). I
would, personally, stick to a strategy of picking up the target project
even if it's big in missing dependencies and grow amount of branches to
the trunk, take a look at <https://issues.guix.gnu.org/68149>.

--
Oleg
Artyom V. Poptsov Oct. 27, 2024, 6:33 a.m. UTC | #2
Merged to the "master" branch as
0734d5a380cc816a90193e37135638b1b87de101

- avp
diff mbox series

Patch

diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index e8b7f7ee9f..0d6debcac4 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -1394,6 +1394,30 @@  (define-public go-github-com-calmh-xdr
 reflection.")
     (license license:expat)))
 
+(define-public go-github-com-caarlos0-env
+  (package
+    (name "go-github-com-caarlos0-env")
+    (version "11.2.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/caarlos0/env")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "074bagdfvsq65i0cak5l7ipci0b1j2m0j8rd54g7rznhqmxwha97"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:import-path "github.com/caarlos0/env"))
+    (home-page "https://github.com/caarlos0/env")
+    (synopsis "Library to parse environment variables into structs")
+    (description
+     "@code{env} is a simple, zero-dependencies library to parse environment
+variables into structs.")
+    (license license:expat)))
+
 (define-public go-github-com-charlievieth-fastwalk
   (package
     (name "go-github-com-charlievieth-fastwalk")