diff mbox series

[bug#52527,4/4] gnu: Add ghc-tidal

Message ID 8b62882634a2bb03f1eea74dc24c0e3e07ee1d91.1639609080.git.avityazev@posteo.org
State New
Headers show
Series gnu: Add ghc-tidal. | expand

Commit Message

Aleksandr Vityazev Dec. 15, 2021, 11:01 p.m. UTC
* gnu/packages/haskell-xyz.scm (ghc-tidal): New variable.
---
 gnu/packages/haskell-xyz.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index a253962142..20e62d85c2 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -29,6 +29,7 @@ 
 ;;; Copyright © 2020 Carlo Holl <carloholl@gmail.com>
 ;;; Copyright © 2020 Christine Lemmer-Webber <cwebber@dustycloud.org>
 ;;; Copyright © 2021 Alice BRENON <alice.brenon@ens-lyon.fr>
+;;; Copyright © 2021 Aleksandr Vityazev <avityazev@posteo.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -3066,6 +3067,32 @@  (define-public ghc-microspec
 dependencies.")
     (license license:bsd-3)))
 
+(define-public ghc-tidal
+  (package
+    (name "ghc-tidal")
+    (version "1.7.8")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (hackage-uri "tidal" version))
+       (sha256
+        (base32 "0l8k4f89rhmvd0ys7klgi57k0313ki1vr256mkc60xc6a6gb3g93"))))
+    (build-system haskell-build-system)
+    (inputs
+     (list ghc-colour
+           ghc-hosc
+           ghc-network
+           ghc-bifunctors
+           ghc-clock
+           ghc-primitive
+           ghc-random))
+    (native-inputs (list ghc-microspec))
+    (home-page "https://tidalcycles.org/")
+    (synopsis "Pattern language for improvised music")
+    (description
+     "Tidal is a domain specific language for live coding patterns.")
+    (license license:gpl3+)))
+
 (define-public ghc-dbus
   (package
     (name "ghc-dbus")