diff mbox series

[bug#67315,1/2] gnu: lean: Use G-expressions.

Message ID 8b5ac18136b62d453b06c3b2b1db3d9bad5b2bac.1700536251.git.all_but_last@163.com
State New
Headers show
Series [bug#67315,1/2] gnu: lean: Use G-expressions. | expand

Commit Message

Zhu Zihao Nov. 21, 2023, 3:54 a.m. UTC
* gnu/packages/lean.scm (lean)[arguments]: Use G-expressions.
---
 gnu/packages/lean.scm | 49 +++++++++++++++++++++++--------------------
 1 file changed, 26 insertions(+), 23 deletions(-)


base-commit: d20ece07dbb09382f361c8bbf0bcab9e83d8b73e

Comments

Ludovic Courtès Dec. 11, 2023, 10:49 p.m. UTC | #1
Hi,

Zhu Zihao <all_but_last@163.com> skribis:

> * gnu/packages/lean.scm (lean)[arguments]: Use G-expressions.

[...]

> * gnu/packages/lean.scm (lean): Update to 3.51.1.
> [home-page]: Use new home page.
> [arguments]<#:phases>: Remove stale phase 'patch-tests-shebangs'.
> [inputs]: Remove bash-minimal.
>
> Change-Id: Ib90a124b4a6b06fb30223ad4b9254249e56dd086

Applied, thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/lean.scm b/gnu/packages/lean.scm
index 12c1849cdb..a8ad085d7e 100644
--- a/gnu/packages/lean.scm
+++ b/gnu/packages/lean.scm
@@ -3,6 +3,7 @@ 
 ;;; Copyright © 2020 Brett Gilio <brettg@gnu.org>
 ;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2022 Pradana Aumars <paumars@courrier.dev>
+;;; Copyright © 2023 Zhu Zihao <all_but_last@163.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -25,6 +26,7 @@  (define-module (gnu packages lean)
   #:use-module (guix build-system cmake)
   #:use-module (guix build-system python)
   #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (guix gexp)
   #:use-module (guix packages)
   #:use-module (guix git-download)
   #:use-module (guix download)
@@ -52,29 +54,30 @@  (define-public lean
     (inputs
      (list bash-minimal gmp))
     (arguments
-     `(#:build-type "Release"           ; default upstream build type
-       ;; XXX: Test phases currently fail on 32-bit sytems.
-       ;; Tests for those architectures have been temporarily
-       ;; disabled, pending further investigation.
-       #:tests? ,(and (not (%current-target-system))
-                      (let ((arch (%current-system)))
-                        (not (or (string-prefix? "i686" arch)
-                                 (string-prefix? "armhf" arch)))))
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'patch-source-shebangs 'patch-tests-shebangs
-           (lambda _
-             (let ((sh (which "sh"))
-                   (bash (which "bash")))
-               (substitute* (find-files "tests/lean" "\\.sh$")
-                 (("#![[:blank:]]?/bin/sh")
-                  (string-append "#!" sh))
-                 (("#![[:blank:]]?/bin/bash")
-                  (string-append "#!" bash))
-                 (("#![[:blank:]]?usr/bin/env bash")
-                  (string-append "#!" bash))))))
-         (add-before 'configure 'chdir-to-src
-           (lambda _ (chdir "src"))))))
+     (list
+      #:build-type "Release"            ; default upstream build type
+      ;; XXX: Test phases currently fail on 32-bit sytems.
+      ;; Tests for those architectures have been temporarily
+      ;; disabled, pending further investigation.
+      #:tests? (and (not (%current-target-system))
+                    (let ((arch (%current-system)))
+                      (not (or (string-prefix? "i686" arch)
+                               (string-prefix? "armhf" arch)))))
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'patch-source-shebangs 'patch-tests-shebangs
+            (lambda _
+              (let ((sh (which "sh"))
+                    (bash (which "bash")))
+                (substitute* (find-files "tests/lean" "\\.sh$")
+                  (("#![[:blank:]]?/bin/sh")
+                   (string-append "#!" sh))
+                  (("#![[:blank:]]?/bin/bash")
+                   (string-append "#!" bash))
+                  (("#![[:blank:]]?usr/bin/env bash")
+                   (string-append "#!" bash))))))
+          (add-before 'configure 'chdir-to-src
+            (lambda _ (chdir "src"))))))
     (synopsis "Theorem prover and programming language")
     (description
      "Lean is a theorem prover and programming language with a small trusted