[bug#78077,electronics-team] gnu: python-vunit: Update to 5.0.0-dev.5.

Message ID 8b2e4e532db477f78a042d9f47386e1280806123.1745688433.git.csantosb@inventati.org
State New
Headers
Series [bug#78077,electronics-team] gnu: python-vunit: Update to 5.0.0-dev.5. |

Commit Message

Cayetano Santos April 26, 2025, 5:27 p.m. UTC
  * gnu/packages/fpga.scm (python-vunit): Update to 5.0.0-dev.5.

Change-Id: Idde0283b73906209799fcc2be9bbb72df8d2aa20
---

Update to release 5.0.0-dev.5, updating 2 years old 4.7.0.

[build-system]: Switch to pyproject-build-system.
[arguments]<#:tests> Activate.
[propgated-inputs]: Remove python.
[native-inputs]: Add all necessary for building and testing.

 gnu/packages/fpga.scm | 21 ++++++++++++++-------
 1 file changed, 14 insertions(+), 7 deletions(-)


base-commit: edeafb19c4a83eb81fe7e47a6a94f238db9cccf1
--
2.49.0
  

Patch

diff --git a/gnu/packages/fpga.scm b/gnu/packages/fpga.scm
index dfbe1a2894..5c83854aef 100644
--- a/gnu/packages/fpga.scm
+++ b/gnu/packages/fpga.scm
@@ -72,6 +72,7 @@  (define-module (gnu packages fpga)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages python)
   #:use-module (gnu packages python-build)
+  #:use-module (gnu packages python-check)
   #:use-module (gnu packages python-xyz)
   #:use-module (gnu packages qt)
   #:use-module (gnu packages readline)
@@ -523,7 +524,7 @@  (define-public python-myhdl
 (define-public python-vunit
   (package
     (name "python-vunit")
-    (version "4.7.0")
+    (version "5.0.0-dev.5") ;v4.7.0 dates back from 2 years ago.
     (source
      (origin
        (method git-fetch)
@@ -533,17 +534,23 @@  (define-public python-vunit
              (recursive? #t)))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "0s7j5bykbv34wgnxy5cl4zp6g0caidvzs8pd9yxjq341543xkjwm"))))
-    (build-system python-build-system)
-    (arguments
-     '(#:tests? #f))                ;XXX: requires setuptools_scm >= 2.0.0, <3
-    (propagated-inputs (list python python-colorama))
+        (base32 "1sfnl1l6bgaqa8c2sk8k8f232bnq2drjg6rg7jvscmyz18yfih0b"))))
+    (build-system pyproject-build-system)
+    (native-inputs (list python-setuptools
+                         python-wheel
+                         ;; tests
+                         nvc
+                         python-mypy
+                         python-coverage
+                         python-pycodestyle
+                         python-pylint
+                         python-pytest))
+    (propagated-inputs (list python-colorama))
     (home-page "https://vunit.github.io")
     (synopsis "Unit testing framework for VHDL/SystemVerilog")
     (description
      "VUnit features the functionality needed to realize continuous and
 automated testing of HDL code.")
-
     ;; According to 'LICENSE.rst', VUnit itself is under MPL but two
     ;; subdirectories are under ASL.
     (license (list license:mpl2.0 license:asl2.0))))