diff mbox series

[bug#56729,RFC,v3,03/32] gnu: Add python-memory-allocator.

Message ID 8b265a6ab32172f0f462c47d1b3a078d24032e20.1685391447.git.guix@ikherbers.com
State New
Headers show
Series None | expand

Commit Message

vicvbcun May 29, 2023, 8:38 p.m. UTC
* gnu/packages/python-xyz.scm (python-memory-allocator): New variable.
---

Notes:
    Previous versions of this commit had `python-cython' as `propagated-input'.

 gnu/packages/python-xyz.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d07561b185..bc3773b510 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -18485,6 +18485,26 @@  (define-public python-memcached
 more, possibly remote, memcached servers.")
     (license license:psfl)))
 
+(define-public python-memory-allocator
+  (package
+    (name "python-memory-allocator")
+    (version "0.1.3")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "memory_allocator" version))
+              (sha256
+               (base32
+                "0qiijpv8zr7c5rjy64i4q3rb8qhn6v4yms5mza4p86y0w4m5r00k"))))
+    (build-system pyproject-build-system)
+    (native-inputs (list python-cython))
+    (home-page "https://github.com/sagemath/memory_allocator")
+    (synopsis "Extension class to allocate memory with cython")
+    (description
+     "This package provides an extension class that provides C-like memory
+allocation methods (e.g. @code{malloc}, @code{aligned_malloc}).  The memory is
+automatically freed if an instance is deallocated.")
+    (license license:gpl3)))
+
 (define-public python-mergedeep
   (package
     (name "python-mergedeep")