diff mbox series

[bug#48099] gnu: Add python-django-3.2.

Message ID 8b10b167-90df-f965-90e1-7195fa96516b@gnu.org
State Accepted
Headers show
Series [bug#48099] gnu: Add python-django-3.2. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Roel Janssen April 29, 2021, 11:06 a.m. UTC
Hi Guix,

I attached a recipe for python-django-3.2.  I haven't tested it beyond 
building it (which includes running the test suite),
so it'd be great to keep version 3.1.8 and let version 3.2 inherit from 
that package.

Kind regards,
Roel Janssen

Comments

Efraim Flashner May 15, 2021, 7:30 p.m. UTC | #1
On Thu, Apr 29, 2021 at 01:06:47PM +0200, Roel Janssen wrote:
> Hi Guix,
> 
> I attached a recipe for python-django-3.2.  I haven't tested it beyond
> building it (which includes running the test suite),
> so it'd be great to keep version 3.1.8 and let version 3.2 inherit from that
> package.
> 
> Kind regards,
> Roel Janssen
> 

Marius pushed a similar patch as
249fb4a30345f6687645911bb22cbf43548b4c4d updating python-django to
3.2.1, and then making some changes to the packages.
diff mbox series

Patch

From f591c97292f04caccc1c23f484a0f439dcec0cdd Mon Sep 17 00:00:00 2001
From: Roel Janssen <roel@gnu.org>
Date: Thu, 29 Apr 2021 13:02:10 +0200
Subject: [PATCH] gnu: Add python-django-3.2.

* gnu/packages/django.scm (python-django-3.2): New variable.
---
 gnu/packages/django.scm | 11 +++++++++++
 1 file changed, 11 insertions(+)

diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index dfc3d314ad..916dc68105 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -129,6 +129,17 @@  to the @dfn{don't repeat yourself} (DRY) principle.")
     (license license:bsd-3)
     (properties `((cpe-name . "django")))))
 
+(define-public python-django-3.2
+  (package (inherit python-django)
+   (name "python-django")
+   (version "3.2")
+   (source (origin
+            (method url-fetch)
+            (uri (pypi-uri "Django" version))
+            (sha256
+             (base32
+              "179qdxa438fnycnnf1j5z6359h1kbp2q7djf01v5jrr26xjgkw11"))))))
+
 (define-public python-django-2.2
   (package
     (inherit python-django)
-- 
2.31.1