[bug#74618] gnu: lcov: disable parallel tests

Message ID 8afcc0bf2961c2b93a41289a8cec7e5a28957b70.1732951981.git.ryan@arctype.co
State New
Headers
Series [bug#74618] gnu: lcov: disable parallel tests |

Commit Message

Ryan Sundberg Nov. 30, 2024, 7:33 a.m. UTC
  `make check` is not reliable for lcov when run in parallel
(e.g. `make -j 24 check`). Disable parallelism for the test suite.

* gnu/packages/code (lcov): Set #:parallel-tests? #f

Signed-off-by: Ryan Sundberg <ryan@arctype.co>
Change-Id: Ibb3618c4786dfbb50b90e725297947458115347c
---
 gnu/packages/code.scm | 1 +
 1 file changed, 1 insertion(+)


base-commit: ce877a777e6ec089dc347e9883387d3080b471cf
  

Comments

Z572 Dec. 1, 2024, 10:45 a.m. UTC | #1
Ryan Sundberg via Guix-patches via <guix-patches@gnu.org> writes:

> `make check` is not reliable for lcov when run in parallel
> (e.g. `make -j 24 check`). Disable parallelism for the test suite.

Please also write this in the comments of the code. Make it easy for
people to know later

>
> * gnu/packages/code (lcov): Set #:parallel-tests? #f
>
> Signed-off-by: Ryan Sundberg <ryan@arctype.co>
> Change-Id: Ibb3618c4786dfbb50b90e725297947458115347c
> ---
>  gnu/packages/code.scm | 1 +
>  1 file changed, 1 insertion(+)
>
> diff --git a/gnu/packages/code.scm b/gnu/packages/code.scm
> index 04ca4dfd6b..6ac514a5b5 100644
> --- a/gnu/packages/code.scm
> +++ b/gnu/packages/code.scm
> @@ -556,6 +556,7 @@ (define-public lcov
>       '(#:test-target "test"
>         #:make-flags (list (string-append "PREFIX="
>                                           (assoc-ref %outputs "out")))
> +       #:parallel-tests? #f
>         #:phases
>         (modify-phases %standard-phases
>           (add-after 'unpack 'patch-references-to-commands
>
> base-commit: ce877a777e6ec089dc347e9883387d3080b471cf
  

Patch

diff --git a/gnu/packages/code.scm b/gnu/packages/code.scm
index 04ca4dfd6b..6ac514a5b5 100644
--- a/gnu/packages/code.scm
+++ b/gnu/packages/code.scm
@@ -556,6 +556,7 @@  (define-public lcov
      '(#:test-target "test"
        #:make-flags (list (string-append "PREFIX="
                                          (assoc-ref %outputs "out")))
+       #:parallel-tests? #f
        #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'patch-references-to-commands