diff mbox series

[bug#74340,v2] gnu: Add stdman.

Message ID 8ac8ea557940d5dff1b53c801d3449c15faee46f.1731600497.git.noelopez@free.fr
State New
Headers show
Series [bug#74340,v2] gnu: Add stdman. | expand

Commit Message

Noé Lopez Nov. 14, 2024, 4:08 p.m. UTC
From: Quanrong <quanrong@mailbox.org>

* gnu/packages/documentation.scm (stdman): New variable.

Change-Id: I4ed70b6ad4208bde4df13d45fd7241096f2469a1
---
 gnu/packages/documentation.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)


base-commit: b790db7589858fc77989b4d1f369c52bca6d6e7c
diff mbox series

Patch

diff --git a/gnu/packages/documentation.scm b/gnu/packages/documentation.scm
index f0e37561f7..44ab571ff8 100644
--- a/gnu/packages/documentation.scm
+++ b/gnu/packages/documentation.scm
@@ -14,6 +14,7 @@ 
 ;;; Copyright © 2022 Maxim Cournoyer <maxim.counoyer@gmail.com>
 ;;; Copyright © 2023 Janneke Nieuwenhuizen <janneke@gnu.org>
 ;;; Copyright © 2024 Felix Gruber <felgru@posteo.net>
+;;; Copyright © 2024 Tomás Ortín Fernández <quanrong@mailbox.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -566,3 +567,29 @@  (define-public stddoc
 supported programming languages.  Markdeep code comments are extracted from stdin and
 printed into stdout as a HTML file.")
       (license license:unlicense))))
+
+(define-public stdman
+  (let ((commit "b7070fe10143411a8d69fe3a9f75e90008a8386d")
+	(revision "0")) ;; Last release is outdated
+    (package
+      (name "stdman")
+      (version (git-version "20240610" revision commit))
+      (source (origin
+		(method git-fetch)
+		(uri (git-reference
+		      (commit commit)
+		      (url "https://github.com/jeaye/stdman")))
+		(sha256
+		 (base32 "0h1gfw4sxic5gx073zmshg4qyz2g142ckgzyj30pk8j708mnl8pz"))))
+      (build-system gnu-build-system)
+      (arguments
+       (list
+	#:tests? #f ; There are no tests.
+	#:phases #~(modify-phases %standard-phases
+		     (delete 'build))))
+      (synopsis "Formatted C++ @code{stdlib} man pages from cppreference")
+      (description "stdman is a tool that provides C++ @code{stdlib} documentation
+archived from cppreference as groff-formated man pages, accessible from the
+@code{man} command.")
+      (home-page "https://github.com/jeaye/stdman")
+      (license license:expat))))