diff mbox series

[bug#63479] gnu: mesa-opencl: Remove reference to patch

Message ID 8a5f461a5c43d0013b6ed876caa11b66a1e283c0.1683874169.git.atai@atai.org
State New
Headers show
Series [bug#63479] gnu: mesa-opencl: Remove reference to patch | expand

Commit Message

Andy Tai May 13, 2023, 5:10 a.m. UTC
Fixes <https://bugs.gnu.org/63456>.

* gnu/packages/patches/mesa-opencl-all-targets.patch: Removed

* gnu/local.mk: Remove reference to mesa-opencl-all-targets.patch

* gnu/packages/gl.scm (mesa-opencl)[source]::Remove patch application of
mesa-opencl-all-targets.patch
---
 gnu/local.mk                                  |  1 -
 gnu/packages/gl.scm                           |  4 +--
 .../patches/mesa-opencl-all-targets.patch     | 25 -------------------
 3 files changed, 1 insertion(+), 29 deletions(-)
 delete mode 100644 gnu/packages/patches/mesa-opencl-all-targets.patch


base-commit: d6f6b57766e95d2fa8af63d4460a2b303ca4d867
diff mbox series

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index 73db48f720..73180be88a 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1561,7 +1561,6 @@  dist_patch_DATA =						\
   %D%/packages/patches/memtest86+-build-reproducibly.patch	\
   %D%/packages/patches/mercurial-hg-extension-path.patch	\
   %D%/packages/patches/mercurial-openssl-compat.patch		\
-  %D%/packages/patches/mesa-opencl-all-targets.patch		\
   %D%/packages/patches/mhash-keygen-test-segfault.patch		\
   %D%/packages/patches/mia-fix-boost-headers.patch		\
   %D%/packages/patches/mia-vtk9.patch				\
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 235b386dad..030c828e5b 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -530,9 +530,7 @@  (define-public mesa-opencl
   (package/inherit mesa
     (name "mesa-opencl")
     (source (origin
-              (inherit (package-source mesa))
-              (patches (cons (search-patch "mesa-opencl-all-targets.patch")
-                             (origin-patches (package-source mesa))))))
+              (inherit (package-source mesa))))
     (arguments
      (substitute-keyword-arguments (package-arguments mesa)
        ((#:configure-flags flags)
diff --git a/gnu/packages/patches/mesa-opencl-all-targets.patch b/gnu/packages/patches/mesa-opencl-all-targets.patch
deleted file mode 100644
index 99d4abcea4..0000000000
--- a/gnu/packages/patches/mesa-opencl-all-targets.patch
+++ /dev/null
@@ -1,25 +0,0 @@ 
-This patch restores LLVM targets needed for OpenCL, *reverting* this
-upstream commit:
-
-  From 80817b6e344258ac9b955f824ebf9019a0fc1610 Mon Sep 17 00:00:00 2001
-  From: Jesse Natalie <jenatali@microsoft.com>
-  Date: Wed, 18 Nov 2020 18:30:30 -0800
-  Subject: [PATCH] meson: Adjust Clover's required LLVM modules
-
-diff --git a/meson.build b/meson.build
-index 6d1607c35a3..f828eb80faa 100644
---- b/meson.build
-+++ a/meson.build
-@@ -1479,10 +1479,9 @@
- endif
- if with_gallium_opencl
-   llvm_modules += [
--    'linker', 'coverage', 'instrumentation', 'ipo', 'irreader',
--    'lto', 'option', 'objcarcopts', 'profiledata'
-+    'all-targets', 'linker', 'coverage', 'instrumentation', 'ipo', 'irreader',
-+    'lto', 'option', 'objcarcopts', 'profiledata',
-   ]
--  llvm_optional_modules += ['frontendopenmp']
- endif
- if with_microsoft_clc
-   llvm_modules += ['target', 'linker', 'irreader', 'option', 'libdriver']