diff mbox series

[bug#69434,v2] gnu: Add python-ldaptor.

Message ID 8a57f790659006fea7b1b69cae08e516cd8ad8bd.1709388891.git.sharlatanus@gmail.com
State New
Headers show
Series [bug#69434,v2] gnu: Add python-ldaptor. | expand

Commit Message

Sharlatan Hellseher March 2, 2024, 2:15 p.m. UTC
* gnu/packages/python-xyz.scm (python-ldaptor): New variable.

Change-Id: If7d2cb7b51bb0ccc85b76d7f2d4b31857e042066
---
 gnu/packages/python-xyz.scm | 49 +++++++++++++++++++++++++++++++++++++
 1 file changed, 49 insertions(+)


base-commit: efdaa885b083e85bd380ca914addfcf32d0834f7
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index fc6e997b6c..71e629896c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -30099,6 +30099,55 @@  (define-public python-ldap3
 library.")
     (license license:lgpl3+)))
 
+(define-public python-ldaptor
+  (package
+    (name "python-ldaptor")
+    (version "21.2.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "ldaptor" version))
+       (sha256
+        (base32 "0n53czn5pyh8923y282spdb7xc8c9rhn0n43bczanjjx6wcynjcc"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list
+      #:test-flags
+      #~(list "-m" "twisted.trial"
+              (string-append "-j" (number->string (parallel-job-count)))
+              "ldaptor")
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-before 'check 'disable-failing-tests
+          (lambda _
+            ;; Testing with Twisted 22.4 results in infinite loop creating
+            ;; temporary config files, see
+            ;; <https://github.com/twisted/ldaptor/issues/238>.
+            (delete-file "ldaptor/test/test_config.py")))
+          (replace 'check
+            (lambda* (#:key tests? test-flags #:allow-other-keys)
+              (when tests?
+                (apply invoke "python" test-flags)))))))
+    (propagated-inputs
+     (list python-passlib
+           python-pyparsing
+           python-six
+           python-twisted-22
+           python-zope-interface))
+    (home-page "https://github.com/twisted/ldaptor")
+    (synopsis "Pure-Python Twisted library for LDAP")
+    (description
+     "This package provides a Python Twisted library for LDAP, which key
+feaatures are:
+@itemize
+@item LDAP client logic
+@item separately-accessible LDAP and BER protocol message generation/parsing
+@item ASCII-format LDAP filter generation and parsing
+@item LDIF format data generation
+@item Samba password changing logic
+@end itemize")
+    (license license:expat)))
+
 (define-public python-boltons
   (package
     (name "python-boltons")