diff mbox series

[bug#54476] gnu: games: Add robotfindskitten.

Message ID 8a0d6013e738fe0ea9fb7808aae2d1e7bc014669.camel@riabenko.com
State Accepted
Headers show
Series [bug#54476] gnu: games: Add robotfindskitten. | expand

Commit Message

Roman Riabenko March 28, 2022, 1:56 p.m. UTC
Hello

I thought that I was working around a local implementation of ncurses,
but now I am convinced that there is a local bug, which I filed a
report against. See issue 54607. [1]

[1]: https://issues.guix.gnu.org/54607

Assuming that the bug will be fixed, there is no need for the snippet
which I proposed in previous patches. I attach a new patch to add
robotfindskitten, which is my offer in place of previous patches.

Meanwhile, even with that bug not being fixed, robotfindskitten is
still playable. It is just monochrome, which is a mode natively
supported by the game design.

Roman

Comments

Liliana Marie Prikler March 28, 2022, 6:34 p.m. UTC | #1
Am Montag, dem 28.03.2022 um 16:56 +0300 schrieb Roman Riabenko:
> Hello
> 
> I thought that I was working around a local implementation of
> ncurses, but now I am convinced that there is a local bug, which I
> filed a report against. See issue 54607. [1]
> 
> [1]: https://issues.guix.gnu.org/54607
> 
> Assuming that the bug will be fixed, there is no need for the snippet
> which I proposed in previous patches. I attach a new patch to add
> robotfindskitten, which is my offer in place of previous patches.
For the record, you are still allowed to patch the source in a snippet
or build phase, but you should add a comment referring to this bug when
doing so.

> Meanwhile, even with that bug not being fixed, robotfindskitten is
> still playable. It is just monochrome, which is a mode natively
> supported by the game design.
Is that purely an aesthetic choice or are there other things to
consider w.r.t. your previous phase?  If "monochrome" means black on
white or vice versa and the game only needs those colors, then sure,
waiting for ncurses to be fixed might be the wiser option.

> +              (uri (string-append "https://github.com/"
> +                                  name
> +                                  "/"
> +                                  name
> +                                  "/releases/download/"
> +                                  version
> +                                  "/"
> +                                  name
> +                                  "-"
> +                                  version
> +                                  ".tar.gz"))
Guix style does not always result in the best possible indentation and
is to be taken with a grain of salt.

> +    (synopsis "Zen Simulation of robot finding kitten")
> +    (description
> +     "In this simulation, you play the part of robot.  Your task is
> to
> +complete the simulation by finding kitten, as is your destiny, and
> indeed your
> +wont.  You (robot) are represented by the # character, and you move
> around with
> +the arrow keys touching things.  If the thing you touch is kitten,
> you get a
> +cute little animation (which was cuter in the DOS version) and the
> simulation
> +ends.  Otherwise, you get a brief description of what it is you
> touched.")
Again, this synopsis and description need some love (grammatically
speaking), but it should also cut down on advertisements for
proprietary systems.

Cheers
diff mbox series

Patch

From 470ab9d236a780425679f4d24776640e7bb766cc Mon Sep 17 00:00:00 2001
From: Roman Riabenko <roman@riabenko.com>
Date: Mon, 28 Mar 2022 16:49:03 +0300
Subject: [PATCH] gnu: games: Add robotfindskitten.

* gnu/packages/games.scm (robotfindskitten): New variable.
---
 gnu/packages/games.scm | 43 ++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 43 insertions(+)

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 8cc29b3487..7a23140508 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -69,6 +69,7 @@ 
 ;;; Copyright © 2021 Christopher Baines <mail@cbaines.net>
 ;;; Copyright © 2021 Foo Chuan Wei <chuanwei.foo@hotmail.com>
 ;;; Copyright © 2022 Yovan Naumovski <yovan@gorski.stream>
+;;; Copyright © 2022 Roman Riabenko <roman@riabenko.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -2250,6 +2251,48 @@  (define-public retux
                      license:gpl2+
                      license:gpl3+)))))
 
+(define-public robotfindskitten
+  ;; Despite what guix lint says, version 2.8284271.702 is newer than
+  ;; 1600003_201b. See ChangeLog for version history.
+  (package
+    (name "robotfindskitten")
+    (version "2.8284271.702")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://github.com/"
+                                  name
+                                  "/"
+                                  name
+                                  "/releases/download/"
+                                  version
+                                  "/"
+                                  name
+                                  "-"
+                                  version
+                                  ".tar.gz"))
+              (sha256
+               (base32
+                "1bwrkxm83r9ajpkd6x03nqvmdfpf5vz6yfy0c97pq3v3ykj74082"))))
+    (build-system gnu-build-system)
+    (arguments
+     '(#:configure-flags '("--enable-silent-rules")
+       #:make-flags ;install to /bin instead of /game
+       (list (string-append "execgamesdir="
+                            (assoc-ref %outputs "out") "/bin"))))
+    (inputs (list ncurses))
+    (outputs '("out" "debug"))
+    ;; The following are the original synopsis and description by the authors.
+    (synopsis "Zen Simulation of robot finding kitten")
+    (description
+     "In this simulation, you play the part of robot.  Your task is to
+complete the simulation by finding kitten, as is your destiny, and indeed your
+wont.  You (robot) are represented by the # character, and you move around with
+the arrow keys touching things.  If the thing you touch is kitten, you get a
+cute little animation (which was cuter in the DOS version) and the simulation
+ends.  Otherwise, you get a brief description of what it is you touched.")
+    (home-page "http://robotfindskitten.org/")
+    (license license:gpl2+)))
+
 (define-public roguebox-adventures
   (package
     (name "roguebox-adventures")

base-commit: 738da660ff51e03b5ef63af9fa81eb50cb222928
-- 
2.34.0