diff mbox series

[bug#50397] Add python-crontab

Message ID 89eb017be5ce1671ac0bf72867ad60c1a227da63.camel@courrier.dev
State Accepted
Headers show
Series [bug#50397] Add python-crontab | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Pradana Adrinusa AUMARS Sept. 5, 2021, 3:58 p.m. UTC
From ff85b76d2f3b70887dfed17e3d8470c0761a7a28 Mon Sep 17 00:00:00 2001
From: Pradana AUMARS <paumars@courrier.dev>
Date: Sun, 5 Sep 2021 17:56:31 +0200
Subject: [PATCH] Add python-crontab

---
 gnu/packages/python-xyz.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

Comments

Xinglu Chen Sept. 6, 2021, 10:59 a.m. UTC | #1
On Sun, Sep 05 2021, Pradana Adrinusa AUMARS via Guix-patches via wrote:

> From ff85b76d2f3b70887dfed17e3d8470c0761a7a28 Mon Sep 17 00:00:00 2001
> From: Pradana AUMARS <paumars@courrier.dev>
> Date: Sun, 5 Sep 2021 17:56:31 +0200
> Subject: [PATCH] Add python-crontab
>
> ---

Lacks proper commit message.  Whoever applies the patch can just copy
it from the v1 patch.

>  gnu/packages/python-xyz.scm | 24 ++++++++++++++++++++++++
>  1 file changed, 24 insertions(+)
>
> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
> index 7c70829de9..625415bb90 100644
> --- a/gnu/packages/python-xyz.scm
> +++ b/gnu/packages/python-xyz.scm
> @@ -108,6 +108,7 @@
>  ;;; Copyright © 2021 Franck Pérignon <franck.perignon@univ-grenoble-alpes.fr>
>  ;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
>  ;;; Copyright © 2021 Simon Streit <simon@netpanic.org>
> +;;; Copyright © 2021 Pradana Aumars <paumars@courrier.dev>
>  ;;;
>  ;;; This file is part of GNU Guix.
>  ;;;
> @@ -26556,3 +26557,26 @@ files and directories and adds a datestamp in standard ISO 8601+ format
>  YYYY-MM-DD at the beginning of the file or directory name.")
>        (home-page "https://github.com/novoid/date2name")
>        (license license:gpl3+))))
> +
> +(define-public python-crontab
> +  (package
> +   (name "python-crontab")
> +   (version "2.5.1")
> +   (source
> +    (origin
> +     (method url-fetch)
> +     (uri (pypi-uri name version))
> +     (sha256
> +      (base32
> +       "0cccrqc10r8781ba81x8r2frs3pl2m4hkm599k5358ak0xr7xgjb"))))
> +   (build-system python-build-system)
> +   (arguments
> +    ;; Comptability tests fail so they are disabled.
> +    `(#:tests? #f))
> +   (inputs
> +    `(("python-dateutil" ,python-dateutil)))
> +   (synopsis "Module for reading and writing crontab files")
> +   (description "This Python module can read, write crontab files, and
> +access the system cron automatically and simply using a direct API.")
> +   (home-page "https://gitlab.com/doctormo/python-crontab/")
> +   (license license:lgpl3+)))
> -- 
> 2.33.0

For some reason I am still not able to apply the patch; I am getting the
same error as before.  I don’t have commit access though, so it doesn’t
matter that much anyway...  Assuming the package builds fine, LGTM!
Nicolas Goaziou Sept. 14, 2021, 6:56 a.m. UTC | #2
Hello,

Pradana Adrinusa AUMARS via Guix-patches via <guix-patches@gnu.org>
writes:

> Subject: [PATCH] Add python-crontab

Applied. Thank you!

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 7c70829de9..625415bb90 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -108,6 +108,7 @@ 
 ;;; Copyright © 2021 Franck Pérignon <franck.perignon@univ-grenoble-alpes.fr>
 ;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
 ;;; Copyright © 2021 Simon Streit <simon@netpanic.org>
+;;; Copyright © 2021 Pradana Aumars <paumars@courrier.dev>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -26556,3 +26557,26 @@  files and directories and adds a datestamp in standard ISO 8601+ format
 YYYY-MM-DD at the beginning of the file or directory name.")
       (home-page "https://github.com/novoid/date2name")
       (license license:gpl3+))))
+
+(define-public python-crontab
+  (package
+   (name "python-crontab")
+   (version "2.5.1")
+   (source
+    (origin
+     (method url-fetch)
+     (uri (pypi-uri name version))
+     (sha256
+      (base32
+       "0cccrqc10r8781ba81x8r2frs3pl2m4hkm599k5358ak0xr7xgjb"))))
+   (build-system python-build-system)
+   (arguments
+    ;; Comptability tests fail so they are disabled.
+    `(#:tests? #f))
+   (inputs
+    `(("python-dateutil" ,python-dateutil)))
+   (synopsis "Module for reading and writing crontab files")
+   (description "This Python module can read, write crontab files, and
+access the system cron automatically and simply using a direct API.")
+   (home-page "https://gitlab.com/doctormo/python-crontab/")
+   (license license:lgpl3+)))