diff mbox series

[bug#65410] gnu: prboom-plus: Fix build.

Message ID 89e503311aee019d19b3c016cb8c579852cd8bb0.1692536100.git.iyzsong@member.fsf.org
State New
Headers show
Series [bug#65410] gnu: prboom-plus: Fix build. | expand

Commit Message

vasilii.smirnov--- via Guix-patches" via Aug. 20, 2023, 12:55 p.m. UTC
From: 宋文武 <iyzsong@member.fsf.org>

* gnu/packages/games.scm (prboom-plus)[arguments]<#:phases>:
Set CFLAGS to '-fcommon'.
---
 gnu/packages/games.scm | 3 +++
 1 file changed, 3 insertions(+)


base-commit: 95a1a819dffa833bdd7a47f272da7ee4ff3260c8

Comments

Liliana Marie Prikler Aug. 20, 2023, 3:43 p.m. UTC | #1
Am Sonntag, dem 20.08.2023 um 20:55 +0800 schrieb iyzsong@envs.net:
> From: 宋文武 <iyzsong@member.fsf.org>
> 
> * gnu/packages/games.scm (prboom-plus)[arguments]<#:phases>:
> Set CFLAGS to '-fcommon'.
> ---
>  gnu/packages/games.scm | 3 +++
>  1 file changed, 3 insertions(+)
> 
> diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
> index a5fa19fc20..4563089326 100644
> --- a/gnu/packages/games.scm
> +++ b/gnu/packages/games.scm
> @@ -2381,6 +2381,9 @@ (define-public prboom-plus
>                                       (assoc-ref %outputs "out")
> "/bin"))
>        #:phases
>        (modify-phases %standard-phases
> +        (add-before 'configure 'set-CFLAGS
> +          (lambda _
> +            (setenv "CFLAGS" "-fcommon")))
Could this be added via #:configure-flags?
宋文武 Aug. 21, 2023, 10:32 a.m. UTC | #2
Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

> Am Sonntag, dem 20.08.2023 um 20:55 +0800 schrieb iyzsong@envs.net:
>> +          (lambda _
>> +            (setenv "CFLAGS" "-fcommon")))
> Could this be added via #:configure-flags?

Yes, updated patch sent, thanks!
diff mbox series

Patch

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index a5fa19fc20..4563089326 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -2381,6 +2381,9 @@  (define-public prboom-plus
                                      (assoc-ref %outputs "out") "/bin"))
       #:phases
       (modify-phases %standard-phases
+        (add-before 'configure 'set-CFLAGS
+          (lambda _
+            (setenv "CFLAGS" "-fcommon")))
         (add-after 'set-paths 'set-sdl'paths
           (lambda* (#:key inputs #:allow-other-keys)
             (setenv "CPATH"