diff mbox series

[bug#71702,29/30] gnu: Add specification-specreduce-data.

Message ID 89a41405d04e9b41a4af7695d604b9b98fa2d6d9.1718966788.git.sharlatanus@gmail.com
State New
Headers show
Series Astronomy update 2024/06 | expand

Commit Message

Sharlatan Hellseher June 21, 2024, 6:38 p.m. UTC
* gnu/packages/specifications.scm (specification-specreduce-data): New variable.

Change-Id: I269cc7eefa12dd8d207da9ac613b5793c3e24c7c
---
 gnu/packages/specifications.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/specifications.scm b/gnu/packages/specifications.scm
index 4e6c7b81ff..6b5e1e6fbe 100644
--- a/gnu/packages/specifications.scm
+++ b/gnu/packages/specifications.scm
@@ -138,3 +138,31 @@  (define-public specification-multihash
 well-established cryptographic hash functions, addressing size + encoding
 considerations.")
       (license (list license:expat license:cc-by-sa3.0)))))
+
+(define-public specification-specreduce-data
+  (let ((commit "dcba1c601348ee3a5797ae2d84a068d83393058e")
+        (revision "0"))
+    (package
+      (name "specification-specreduce-data")
+      (version (git-version "0.0.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/astropy/specreduce-data")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "1c6mrjfykkfbbyg489h7czr65nz6bcb3gszz5xa2cg2ccs00m8ii"))))
+      (build-system copy-build-system)
+      (arguments
+       '(#:install-plan '(("specreduce_data/" "share/specreduce_data//"))
+         #:phases (modify-phases %standard-phases
+                    (delete 'strip))))
+      (home-page "https://specreduce.readthedocs.io/")
+      (synopsis "Reference and calibration data for the reducing optical/IR spectra")
+      (description
+       "This package provides a general reference and calibration data for
+spectroscopic data reduction (e.g. standard star spectra, atmospheric
+extinction curves, line lists for calibration lamps).")
+      (license license:bsd-3))))