diff mbox series

[bug#38352] gnome-font-viewer V2

Message ID 89a2de2c1ae7cf22f026398d28f9f4b4a9bfdd82.camel@disroot.org
State Accepted
Headers show
Series [bug#38352] gnome-font-viewer V2 | expand

Commit Message

Raghav Gururajan Dec. 21, 2019, 4:17 a.m. UTC
Hello Guix!

Please find the new patch attached with this email, for gnome-font-
viewer.

Thank you!

Regards,
Raghav Gururajan.
diff mbox series

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index dab2571fba..ba1de82b41 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -746,6 +746,33 @@  accessing key stores.  It also provides the viewer for crypto files on the
 GNOME Desktop.")
     (license license:lgpl2.1+)))
 
+(define-public gnome-font-viewer
+  (package
+    (name "gnome-font-viewer")
+    (version "3.30.0")
+    (source (origin
+	      (method url-fetch)
+	      (uri (string-append "mirror://gnome/sources/gnome-font-viewer/"
+				  (version-major+minor version) "/gnome-font-viewer-" version ".tar.xz"))
+	      (sha256
+	       (base32 
+		"1wwnx2zrlbd2d6np7m9s78alx6j6ranrnh1g2z6zrv9qcj8rpzz5"))))
+    (build-system meson-build-system)
+    (native-inputs
+     `(("glib:bin" ,glib "bin")
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("desktop-file-utils" ,desktop-file-utils)
+       ("gettext" ,gettext-minimal)
+       ("glib" ,glib)
+       ("gnome-desktop" ,gnome-desktop)
+       ("gtk+" ,gtk+)))
+    (synopsis "GNOME Fonts")
+    (description "Application to show you the fonts installed on your computer for your use as thumbnails.
+                  Selecting any thumbnails shows the full view of how the font would look under various sizes.")
+    (home-page "https://gitlab.gnome.org/GNOME/gnome-font-viewer")
+    (license license:gpl2+))
+
 (define-public libgnome-keyring
   (package
     (name "libgnome-keyring")