diff mbox series

[bug#38840] update python-py3status 3.21 to python-xyz.scm

Message ID 89859462-a59c-b20e-ef98-b6efb3b44aab@moncourriel.eu
State Work in progress
Headers show
Series [bug#38840] update python-py3status 3.21 to python-xyz.scm | expand

Commit Message

Thierry Dec. 31, 2019, 10:42 p.m. UTC

Comments

Marius Bakke Jan. 12, 2020, 9:13 p.m. UTC | #1
thierry@moncourriel.eu writes:

> From c759d206188cbabb17198614247dbbeb9d4803bf Mon Sep 17 00:00:00 2001
> From: Grillon <thierry@moncourriel.eu>
> Date: Tue, 31 Dec 2019 23:25:55 +0100
> Subject: [PATCH] gnu: python-py3status: Update file dependency
>
> * gnu/packages/python-xyz.scm (python-py3status): Update file as
> propagated dependecy

Thanks!  Do you know how "file" is used for py3status?  Ideally we would
patch all invokations of "file" so that it uses the absolute file name,
instead of propagating it, along these lines:

  (substitute* "foo.py"
    (("'file'") (string-append "'" (which "file") "'")))

Can you see if such an approach is feasible for python-py3status?
Christopher Baines Nov. 20, 2020, 8:19 p.m. UTC | #2
Marius Bakke <mbakke@fastmail.com> writes:

> thierry@moncourriel.eu writes:
>
>> From c759d206188cbabb17198614247dbbeb9d4803bf Mon Sep 17 00:00:00 2001
>> From: Grillon <thierry@moncourriel.eu>
>> Date: Tue, 31 Dec 2019 23:25:55 +0100
>> Subject: [PATCH] gnu: python-py3status: Update file dependency
>>
>> * gnu/packages/python-xyz.scm (python-py3status): Update file as
>> propagated dependecy
>
> Thanks!  Do you know how "file" is used for py3status?  Ideally we would
> patch all invokations of "file" so that it uses the absolute file name,
> instead of propagating it, along these lines:
>
>   (substitute* "foo.py"
>     (("'file'") (string-append "'" (which "file") "'")))
>
> Can you see if such an approach is feasible for python-py3status?

It's been a few months, is this patch still relevant?

Thanks,

Chris
Marius Bakke Nov. 20, 2020, 9:17 p.m. UTC | #3
Christopher Baines <mail@cbaines.net> skriver:

> Marius Bakke <mbakke@fastmail.com> writes:
>
>> thierry@moncourriel.eu writes:
>>
>>> From c759d206188cbabb17198614247dbbeb9d4803bf Mon Sep 17 00:00:00 2001
>>> From: Grillon <thierry@moncourriel.eu>
>>> Date: Tue, 31 Dec 2019 23:25:55 +0100
>>> Subject: [PATCH] gnu: python-py3status: Update file dependency
>>>
>>> * gnu/packages/python-xyz.scm (python-py3status): Update file as
>>> propagated dependecy
>>
>> Thanks!  Do you know how "file" is used for py3status?  Ideally we would
>> patch all invokations of "file" so that it uses the absolute file name,
>> instead of propagating it, along these lines:
>>
>>   (substitute* "foo.py"
>>     (("'file'") (string-append "'" (which "file") "'")))
>>
>> Can you see if such an approach is feasible for python-py3status?
>
> It's been a few months, is this patch still relevant?

It looks like this was fixed by Jakub in
6a6b8a3fcfc35a5e7b10e7c2a9a75e909354d4d6.  Closing, thanks for the
reminder!
diff mbox series

Patch

From c759d206188cbabb17198614247dbbeb9d4803bf Mon Sep 17 00:00:00 2001
From: Grillon <thierry@moncourriel.eu>
Date: Tue, 31 Dec 2019 23:25:55 +0100
Subject: [PATCH] gnu: python-py3status: Update file dependency

* gnu/packages/python-xyz.scm (python-py3status): Update file as
propagated dependecy
---
 gnu/packages/python-xyz.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9b71982c3a..f5d95562c2 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -9897,7 +9897,7 @@  to occurrences in strings and comments.")
        (sha256
         (base32 "16z8zq83hxy48g6hh4xczbdz50qvxv9k1aahr4fqq7jis60cc262"))))
     (build-system python-build-system)
-    (inputs
+    (propagated-inputs
      `(("file" ,file)))
     (arguments
      '(#:phases
-- 
2.24.1