diff mbox series

[bug#70001] gnu: reprotest: Add missing propogated inputs

Message ID 896f9b471c98c4cbba81bd02b961860421e84b1a.1711393455.git.skyvine@protonmail.com
State New
Headers show
Series [bug#70001] gnu: reprotest: Add missing propogated inputs | expand

Commit Message

Skyler Ferris March 25, 2024, 7:16 p.m. UTC
From: Skyler Ferris <skyvine@protonmail.com>

* gnu/packages/diffoscope.scm (reprotest): Add bash, coreutils,
diffoscope, disorderfs, findutils, grep, inetutils, libfaketime,
and util-linux as propagated inputs.

Change-Id: Ibc113558032697be9048bebe54ba7678156667b9
---
 gnu/packages/diffoscope.scm | 14 ++++++++++++++
 1 file changed, 14 insertions(+)


base-commit: 76a3414a1bc500626a9feca013673f994eb51a34
diff mbox series

Patch

diff --git a/gnu/packages/diffoscope.scm b/gnu/packages/diffoscope.scm
index 52f615f2cf..b87ed74874 100644
--- a/gnu/packages/diffoscope.scm
+++ b/gnu/packages/diffoscope.scm
@@ -29,12 +29,14 @@  (define-module (gnu packages diffoscope)
   #:use-module (gnu packages android)
   #:use-module (gnu packages backup)
   #:use-module (gnu packages base)
+  #:use-module (gnu packages bash)
   #:use-module (gnu packages bootloaders)
   #:use-module (gnu packages cdrom)
   #:use-module (gnu packages check)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages cpio)
   #:use-module (gnu packages dbm)
+  #:use-module (gnu packages file-systems)
   #:use-module (gnu packages gettext)
   #:use-module (gnu packages ghostscript)
   #:use-module (gnu packages gnome)
@@ -258,6 +260,18 @@  (define-public reprotest
         (base32 "1992wlkil07fmj64lw3i7l16dgkkzphz0f932hbkkj9rlcamdwxd"))))
     (inputs
      (list python-debian python-distro python-libarchive-c python-rstr))
+    (propagated-inputs
+     (list
+       bash         ; the python code sets up shell scripts to be executed
+       coreutils    ; tests: locale, exec_path, home ("env")
+       diffoscope   ; used to display diffs when builds are not reproducible
+       disorderfs   ; test: fileordering, but fuse-2 and sudo must be installed as
+                    ; setuid programs as well.
+       findutils    ; __init__ uses "find" to get the hash of multiple files
+       grep         ; tests: kernel
+       inetutils    ; tests: domain_host ("hostname")
+       libfaketime  ; tests: time
+       util-linux)) ; tests: num_cpus ("taskset")
     (native-inputs
      `(("diffoscope" ,diffoscope)
        ("help2man" ,help2man)