diff mbox series

[bug#65701] gnu: portfolio: Update to 1.0.0.

Message ID 896c5a8b68e932ac58297a837cafef051d04240d.1693660352.git.liliana.prikler@gmail.com
State New
Headers show
Series [bug#65701] gnu: portfolio: Update to 1.0.0. | expand

Commit Message

Liliana Marie Prikler Sept. 2, 2023, 1:11 p.m. UTC
* gnu/packages/gnome-xyz.scm (portfolio): Update to 1.0.0.
[#:phases]: Add ‘skip-gtk-update-icon-cache’.
[inputs]: Replace gtk+ with gtk.
Replace libhandy with libadwaita.
[native-inputs]: Remove gtk+:bin.
Add pkg-config.
---
 gnu/packages/gnome-xyz.scm | 12 ++++++++----
 1 file changed, 8 insertions(+), 4 deletions(-)


base-commit: 9179775b0535ddf038d45f1355f759c4d6dc40dc
prerequisite-patch-id: a6de0ccc2665854539d331239e51c5fa4c3373aa

Comments

Maxim Cournoyer Sept. 5, 2023, 3:40 a.m. UTC | #1
Hello,

Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

> * gnu/packages/gnome-xyz.scm (portfolio): Update to 1.0.0.
> [#:phases]: Add ‘skip-gtk-update-icon-cache’.
> [inputs]: Replace gtk+ with gtk.
> Replace libhandy with libadwaita.
> [native-inputs]: Remove gtk+:bin.
> Add pkg-config.

LGTM, thanks!
Liliana Marie Prikler Sept. 9, 2023, 9:03 a.m. UTC | #2
Am Montag, dem 04.09.2023 um 23:40 -0400 schrieb Maxim Cournoyer:
> Hello,
> 
> Liliana Marie Prikler <liliana.prikler@gmail.com> writes:
> 
> > * gnu/packages/gnome-xyz.scm (portfolio): Update to 1.0.0.
> > [#:phases]: Add ‘skip-gtk-update-icon-cache’.
> > [inputs]: Replace gtk+ with gtk.
> > Replace libhandy with libadwaita.
> > [native-inputs]: Remove gtk+:bin.
> > Add pkg-config.
> 
> LGTM, thanks!
Thanks for checking, pushed.

Cheers
diff mbox series

Patch

diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 6ba0ee0092..8b5dc3030e 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -484,7 +484,7 @@  (define-public gnome-plots
 (define-public portfolio
   (package
     (name "portfolio")
-    (version "0.9.14")
+    (version "1.0.0")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -493,7 +493,7 @@  (define-public portfolio
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "0h09v8lhz3kv6qmwjhx3gr7rp6ccfhrzm54gjnaixl4dcg9zddls"))))
+                "1ai9mx801m5lngkljg42vrpvhbvc3071sp4jypsvbzw55hxnn5ba"))))
     (arguments
      (list #:glib-or-gtk? #t
            #:imported-modules `(,@%meson-build-system-modules
@@ -508,6 +508,10 @@  (define-public portfolio
                             (with-directory-excursion (string-append #$output
                                                                      "/bin")
                               (symlink "dev.tchx84.Portfolio" "portfolio"))))
+                        (add-after 'unpack 'skip-gtk-update-icon-cache
+                          (lambda _
+                            (substitute* "build-aux/meson/postinstall.py"
+                              (("gtk-update-icon-cache") "true"))))
                         (add-after 'glib-or-gtk-wrap 'python-and-gi-wrap
                           (lambda* (#:key inputs outputs #:allow-other-keys)
                             (wrap-program (search-input-file outputs
@@ -519,12 +523,12 @@  (define-public portfolio
                               `("GI_TYPELIB_PATH" =
                                 (,(getenv "GI_TYPELIB_PATH")))))))))
     (build-system meson-build-system)
-    (inputs (list bash-minimal python-pygobject gtk+ libhandy))
+    (inputs (list bash-minimal python-pygobject gtk libadwaita))
     (native-inputs
      (list desktop-file-utils
            gettext-minimal
            `(,glib "bin")
-           `(,gtk+ "bin")
+           pkg-config
            python))
     (home-page "https://github.com/tchx84/Portfolio")
     (synopsis "Minimalist file manager for Linux mobile devices")