[bug#77371,12/12] gnu: Add python-hepstats.

Message ID 8950455c7584af53ca3bce26383f950356a8511e.1743288280.git.monego@posteo.net
State New
Headers
Series Add packages from the scikit-hep project |

Commit Message

Vinicius Monego March 29, 2025, 11:01 p.m. UTC
  * gnu/packages/python-science.scm (python-hepstats): New variable.

Change-Id: I0fc06ac9cde4443d2ec973f25985b5161d4ee33c
---
 gnu/packages/python-science.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
  

Patch

diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 41504b457e..ca684fbadc 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -46,6 +46,7 @@ 
 (define-module (gnu packages python-science)
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (gnu packages)
+  #:use-module (gnu packages astronomy)
   #:use-module (gnu packages base)
   #:use-module (gnu packages bioinformatics)
   #:use-module (gnu packages boost)
@@ -1236,6 +1237,33 @@  (define-public python-vector
 in a Python @code{for} loop.")
     (license license:bsd-3)))
 
+(define-public python-hepstats
+  (package
+    (name "python-hepstats")
+    (version "0.9.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "hepstats" version))
+       (sha256
+        (base32 "1rvvc3r83p41c5mpsy5l02r97zrylamgm1gmxs988csysiqri4ng"))))
+    (build-system pyproject-build-system)
+    (propagated-inputs (list python-asdf
+                             python-numpy
+                             python-pandas
+                             python-scipy
+                             python-tqdm
+                             python-uhi))
+    (native-inputs (list python-hatch-vcs
+                         python-hatchling
+                         python-pytest
+                         python-pytest-runner))
+    (home-page "https://github.com/scikit-hep/hepstats")
+    (synopsis "Statistics tools and utilities")
+    (description "@code{hepstats} is a library for statistical inference
+aiming to cover the needs of High Energy Physics.")
+    (license license:bsd-3)))
+
 (define-public python-trimesh
   (package
     (name "python-trimesh")