diff mbox series

[bug#72125,1/4] gnu: python-protobuf: Update to 5.27.2.

Message ID 891a0c8b9709c11508a9b45a61dd0a46169a365d.1721040408.git.sisiutl@egregore.fun
State New
Headers show
Series gajim: Update to latest version | expand

Commit Message

Sisiutl July 15, 2024, 5:28 p.m. UTC
Change-Id: Ibaf04dd3d66789ab0e2407e25e1a79e55f4d6e4d
---
 gnu/packages/protobuf.scm | 14 +++++++-------
 1 file changed, 7 insertions(+), 7 deletions(-)

Comments

jgart July 15, 2024, 9:27 p.m. UTC | #1
Hi,

I can't apply your patch with `mumi am`:

$ mumi current 72125
$ mumi am -- -s -S
Backtrace:
           3 (primitive-load "/gnu/store/p3xfvin2a76618144l39i4nn17a…")
In mumi/client.scm:
   701:26  2 (am-reroll-count #:reroll-count _ #:dry-run? _ # _)
In srfi/srfi-1.scm:
   365:28  1 (take-right (#<<patch> subject: "[PATCH 0/4] gajim: U…>) …)
In unknown file:
           0 (list-tail (#<<patch> subject: "[PATCH 0/4] gajim: Up…>) …)

ERROR: In procedure list-tail:
In procedure list-tail: Wrong type argument in position 1 (expecting
pair): ()

How was it that you sent it?
Sisiutl July 15, 2024, 11:09 p.m. UTC | #2
jgart <jgart@dismail.de> writes:

> Hi,
>
> I can't apply your patch with `mumi am`:
>
> How was it that you sent it?

Hi!

I sent them using git send-mail.

I think the problem comes from my end. The mail server apparently didn't
send the patches 2, 3 and 4 to debbugs, so I had to resend them using
the guix-patches address and putting the bug tag in the subject line.

I think it may work now. Thank you!
宋文武 July 30, 2024, 11:57 a.m. UTC | #3
Gisement <sisiutl@egregore.fun> writes:

> Change-Id: Ibaf04dd3d66789ab0e2407e25e1a79e55f4d6e4d
> ---
>  gnu/packages/protobuf.scm | 14 +++++++-------
>  1 file changed, 7 insertions(+), 7 deletions(-)
>
> diff --git a/gnu/packages/protobuf.scm b/gnu/packages/protobuf.scm
> index d47b67fa61..ef91a1b838 100644
> --- a/gnu/packages/protobuf.scm
> +++ b/gnu/packages/protobuf.scm
> @@ -429,21 +429,21 @@ (define-public python-nanopb
>  (define-public python-protobuf
>    (package
>      (name "python-protobuf")
> -    (version "3.20.2")
> +    (version "5.27.2")

Hello, this will broke packages (eg: onnx) which still depends on
protobuf < 4, the packages list can be get via:
  guix refresh --list-dependent python-protobuf

I guess onnx is not the only one will fail.

Maybe introduce as a new 'python-protobuf-5' package?
diff mbox series

Patch

diff --git a/gnu/packages/protobuf.scm b/gnu/packages/protobuf.scm
index d47b67fa61..ef91a1b838 100644
--- a/gnu/packages/protobuf.scm
+++ b/gnu/packages/protobuf.scm
@@ -429,21 +429,21 @@  (define-public python-nanopb
 (define-public python-protobuf
   (package
     (name "python-protobuf")
-    (version "3.20.2")
+    (version "5.27.2")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "protobuf" version))
        (sha256
-        (base32
-         "0l0p2lczs5iahgkhzm3298pjl49bk9iiwngkglg7ll7fkqqwlbbi"))))
+        (base32 "0517bvr76daiwnz3jb099mckmklh5kzjg0pjfmh8bbxr4vrdxv7k"))))
     (build-system python-build-system)
     (inputs (list protobuf))
+    ;; The library moved to upb, a C implementation faster than C++ and
+    ;; native python. It requires no special installation.
     (arguments
-     `(;; Favor C++ implementation from protobuf over the native Python
-       ;; implementation. The additional dependency yields significant
-       ;; performance improvements for some workloads.
-       #:configure-flags '("--cpp_implementation")))
+     ;; There are no tests.
+     (list
+      #:tests? #f))
     (home-page "https://github.com/google/protobuf")
     (synopsis "Protocol buffers is a data interchange format")
     (description