diff mbox series

[bug#70092] gnu: Add go-1.22.

Message ID 890b87b179f713ad14e8de849d92a25e1d483cc1.1711822941.git.rodion.goritskov@gmail.com
State New
Headers show
Series [bug#70092] gnu: Add go-1.22. | expand

Commit Message

Rodion Goritskov March 30, 2024, 6:22 p.m. UTC
* gnu/packages/golang.scm (go-1.22): New variable.

Change-Id: I3a5e4ddf28471602344cd042820b3d23f6113fa9
---
 gnu/packages/golang.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)


base-commit: 350cdbe83819233b6db9fb1cfc797eaf80b0d168
prerequisite-patch-id: c54d19e7e00697430d955942249f8ac06a0d5e0d

Comments

Sharlatan Hellseher March 30, 2024, 8:15 p.m. UTC | #1
Hi,

The fresh golang is in go-team branch.

I need to set up CI to check the build,  or wait for someone with
admin rights to ci.guix.gnu.org to set ^.^

Thanks,
Oleg
Maxim Cournoyer April 1, 2024, 12:36 a.m. UTC | #2
Hi Sharlatan,

Sharlatan Hellseher <sharlatanus@gmail.com> writes:

> Hi,
>
> The fresh golang is in go-team branch.
>
> I need to set up CI to check the build,  or wait for someone with
> admin rights to ci.guix.gnu.org to set ^.^

I've just sent you a TLS cert for Cuirass; you should now be able to
manage this yourself (i.e. create the job specification for the go-team
branch) via the Cuirass web interface.
Rodion Goritskov April 1, 2024, 11:16 a.m. UTC | #3
close 70092
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 385da42eda..f0940f4586 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1114,6 +1114,31 @@  (define-public go-1.21
                      ("api"          "share/go/api"        ,tests)
                      ("test"         "share/go/test"       ,tests))))))))))))
 
+(define-public go-1.22
+  (package
+    (inherit go-1.21)
+    (name "go")
+    (version "1.22.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/golang/go")
+             (commit (string-append "go" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "01zz8n5c32vympr2l9jdg5pzn63d3z28p0d4q6wmd0pr2jd3l3wn"))))
+    (arguments
+     (substitute-keyword-arguments (package-arguments go-1.21)
+       ((#:phases phases)
+        #~(modify-phases #$phases
+            (delete 'unpatch-perl-shebangs)))))
+    (native-inputs
+     ;; Go 1.22 requires Go 1.20 or later as the bootstrap toolchain.
+     (alist-replace "go"
+                    (list go-1.21)
+                    (package-native-inputs go-1.21)))))
+
 (define-public go go-1.17)
 
 (define make-go-std
@@ -1157,6 +1182,7 @@  (define-public go-std-1.18 (make-go-std go-1.18))
 (define-public go-std-1.19 (make-go-std go-1.19))
 (define-public go-std-1.20 (make-go-std go-1.20))
 (define-public go-std-1.21 (make-go-std go-1.21))
+(define-public go-std-1.22 (make-go-std go-1.22))
 
 (define-public go-0xacab-org-leap-shapeshifter
   (let ((commit "0aa6226582efb8e563540ec1d3c5cfcd19200474")