diff mbox series

[bug#68260] gnu: fish-foreign-env: Update to 0.20230823.

Message ID 889d4b47504a8e7d395a5dd0b3833cb0bb3e9a8b.1704453996.git.tanguy@bioneland.org
State New
Headers show
Series [bug#68260] gnu: fish-foreign-env: Update to 0.20230823. | expand

Commit Message

Tanguy LE CARROUR Jan. 5, 2024, 11:36 a.m. UTC
Hi Guix,

Long time not contributed, but… this one should be trivial! … 🤞

Regards
Tanguy

* gnu/packages/shells.scm (fish-foreign-env): Update to 0.20230823.
[arguments]: Do no substitute in file that no longer exists.
---
 gnu/packages/shells.scm | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)


base-commit: ac69b423865f12310cef5662d9c303aa4b90c869

Comments

Ludovic Courtès Jan. 14, 2024, 9:56 p.m. UTC | #1
Hello!

Tanguy Le Carrour <tanguy@bioneland.org> skribis:

> * gnu/packages/shells.scm (fish-foreign-env): Update to 0.20230823.
> [arguments]: Do no substitute in file that no longer exists.

Applied, thanks! :-)

Ludo’.
Tanguy LE CARROUR Jan. 15, 2024, 7:41 a.m. UTC | #2
Hi Ludo’,


Quoting Ludovic Courtès (2024-01-14 22:56:05)
> Tanguy Le Carrour <tanguy@bioneland.org> skribis:
> 
> > * gnu/packages/shells.scm (fish-foreign-env): Update to 0.20230823.
> > [arguments]: Do no substitute in file that no longer exists.
> 
> Applied, thanks! :-)

Thaaaanks!
diff mbox series

Patch

diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index 8d2aadc0aa..e3de0eb205 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -22,6 +22,7 @@ 
 ;;; Copyright © 2022 Andrew Tropin <andrew@trop.in>
 ;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
 ;;; Copyright © 2023 David Pflug <david@pflug.io>
+;;; Copyright © 2024 Tanguy Le Carrour <tanguy@bioneland.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -273,16 +274,16 @@  (define-public fish
 (define-public fish-foreign-env
   (package
     (name "fish-foreign-env")
-    (version "0.20190116")
+    (version "0.20230823")
     (source
      (origin
        (method git-fetch)
        (uri (git-reference
              (url "https://github.com/oh-my-fish/plugin-foreign-env")
-             (commit "dddd9213272a0ab848d474d0cbde12ad034e65bc")))
+             (commit "7f0cf099ae1e1e4ab38f46350ed6757d54471de7")))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "00xqlyl3lffc5l0viin1nyp819wf81fncqyz87jx8ljjdhilmgbs"))))
+        (base32 "0d16mdgjdwln41zk44qa5vcilmlia4w15r8z2rc3p49i5ankksg3"))))
     (build-system trivial-build-system)
     (arguments
      '(#:modules ((guix build utils))
@@ -298,7 +299,6 @@  (define-public fish-foreign-env
 
            ;; Embed absolute paths.
            (substitute* `(,(string-append func-path "/fenv.fish")
-                          ,(string-append func-path "/fenv.apply.fish")
                           ,(string-append func-path "/fenv.main.fish"))
              (("bash")
               (search-input-file %build-inputs "/bin/bash"))