diff mbox series

[bug#62084] gnu: Add python-dlmanager.

Message ID 889bae53-8018-50bb-5f0c-64db08ab2fb5@disroot.org
State New
Headers show
Series [bug#62084] gnu: Add python-dlmanager. | expand

Commit Message

Adam Faiz March 9, 2023, 5:26 p.m. UTC
From 31791297ec5bf5bbeaf4412aa654618320db6646 Mon Sep 17 00:00:00 2001
Message-Id: <31791297ec5bf5bbeaf4412aa654618320db6646.1678382603.git.adam.faiz@disroot.org>
In-Reply-To: <f788ce8ebc205a6e05bcc270865d793d94bf51e9.1678382602.git.adam.faiz@disroot.org>
References: <f788ce8ebc205a6e05bcc270865d793d94bf51e9.1678382602.git.adam.faiz@disroot.org>
From: AwesomeAdam54321 <adam.faiz@disroot.org>
Date: Fri, 10 Mar 2023 00:32:21 +0800
Subject: [PATCH] gnu: Add python-dlmanager.

* gnu/packages/python-xyz.scm (python-dlmanager): New variable.
---
  gnu/packages/python-xyz.scm | 35 +++++++++++++++++++++++++++++++++++
  1 file changed, 35 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5f695da802..439d6f058e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -28260,6 +28260,41 @@  (define-public python-djvulibre
      (home-page "https://jwilk.net/software/python-djvulibre")
      (license license:gpl2)))
  
+(define-public python-dlmanager
+  (package
+    (name "python-dlmanager")
+    (version "0.1.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/parkouss/dlmanager")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0f2j7d396z50yd5r86jx8m5bxyv2i0cw967j68xcwpcg3b216zmr"))
+              (modules '((guix build utils)))
+              (snippet
+               #~(begin
+                   (substitute* "setup.py"
+                     (("pytest.main.self.pytest_args.")
+                      "pytest.main(self.pytest_args.split(' '))"))))))
+    (build-system python-build-system)
+    (native-inputs
+     (list python-pytest python-mock))
+    (propagated-inputs
+     (list python-requests python-six))
+    (home-page "https://github.com/parkouss/dlmanager")
+    (synopsis "Download manager library")
+    (description
+     "@code{dlmanager} is a download manager library,
+with the following features:\n
+* Download files in background and in parallel\n
+* Cancel downloads\n
+* Store downloads in a given directory, avoiding re-downloading files\n
+* Limit the size of this directory, removing oldest files.")
+    (license license:gpl3+)))
+
  (define-public python-version
    ;; No version tags available in the git repo; just using bare commit instead.
    (let ((commit "5232eea250ab72cc5cb72b0b75efb35d2192b906")