diff mbox series

[bug#69167] gnu: r-harmony: Update to 1.2.0.

Message ID 88868cdb132cbdd5e0a39ef61d271e9cb9397be4.1708011619.git.navid.afkhami@mdc-berlin.de
State New
Headers show
Series [bug#69167] gnu: r-harmony: Update to 1.2.0. | expand

Commit Message

nafkhamdc Feb. 15, 2024, 3:40 p.m. UTC
* gnu/packages/cran.scm (r-harmony): Update to 1.2.0.
[propagated-inputs]: Remove r-irlba and r-tidyr; add r-rhpcblasctl.
[native-inputs]: Remove autoconf; add r-knitr.

Change-Id: I3c554bbb29ccc2b8a24d2d46e362b7d7cae56c1c
---
 gnu/packages/cran.scm | 52 +++++++++++++++++--------------------------
 1 file changed, 20 insertions(+), 32 deletions(-)


base-commit: 2ba2875dbda4b080fcad4e6d672bb4104d59dd0c
prerequisite-patch-id: 4e4ac5c149de95802186383997235d855b9d08de
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 3b8ad2baac..fa28814827 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -26934,44 +26934,32 @@  (define-public r-liger
 (define-public r-harmony
   (package
     (name "r-harmony")
-    (version "0.1")
+    (version "1.2.0")
     (source
      (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/immunogenomics/harmony")
-             (commit version)))
-       (file-name (git-file-name name version))
+       (method url-fetch)
+       (uri (cran-uri "harmony" version))
        (sha256
-        (base32
-         "05r401q09rbr6fqhb9mbd95082cjdi3nag1cv6zn96xkr0f6imq9"))
-       (modules '((guix build utils)))
-       (snippet
-        '(begin
-           (for-each delete-file '("config.status" "configure"))
-           #t))))
+        (base32 "1df7bb9ba3m0c44fhmh8cs4hlkh4fffjwm8rz7l87lf5pdy7sg56"))))
+    (properties `((upstream-name . "harmony")))
     (build-system r-build-system)
-    (propagated-inputs
-     (list r-cowplot
-           r-dplyr
-           r-ggplot2
-           r-irlba
-           r-matrix
-           r-rcpp
-           r-rcpparmadillo
-           r-rcppprogress
-           r-rlang
-           r-tibble
-           r-tidyr))
-    (native-inputs
-     (list autoconf))
-    (home-page "https://github.com/immunogenomics/harmony")
+    (propagated-inputs (list r-cowplot
+                             r-dplyr
+                             r-ggplot2
+                             r-matrix
+                             r-rcpp
+                             r-rcpparmadillo
+                             r-rcppprogress
+                             r-rhpcblasctl
+                             r-rlang
+                             r-tibble))
+    (native-inputs (list r-knitr))
+    (home-page "https://cran.r-project.org/web/packages/harmony/index.html")
     (synopsis "Integration of single cell sequencing data")
     (description
-     "This package provides an implementation of the Harmony algorithm for
-single cell integration, described in Korsunsky et al
-@url{doi.org/10.1101/461954}.  The package includes a standalone Harmony
-function and interfaces to external frameworks.")
+     "Implementation of the Harmony algorithm for single cell integration.
+This package includes a standalone Harmony function and interfaces to
+external frameworks.")
     (license license:gpl3)))
 
 (define-public r-covr