bug#34724: Guix patch: emacs-debpaste

Message ID 87zhq1rroe.fsf@gnu.org
State Accepted
Headers show
Series bug#34724: Guix patch: emacs-debpaste | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Ludovic Courtès March 11, 2019, 10:07 p.m. UTC
Hi Brian,

I applied the first patch with these changes to address issues reported
by ‘guix lint’:
Likewise for the second patch:
I also tweaked the commit log to follow our conventions.

Please do not miss
<https://www.gnu.org/software/guix/manual/en/html_node/Submitting-Patches.html>
for your future contributions.

Thank you!

Ludo’.

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 8d521cffce..69ea0b3b74 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -11362,24 +11362,23 @@  Org-mode.  It features:
   (package
     (name "emacs-debpaste")
     (version "0.1.5")
+    (home-page "https://github.com/alezost/debpaste.el")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append
-             "https://github.com/alezost/debpaste.el/archive/v"
-             version ".tar.gz"))
+       (method git-fetch)
+       (uri (git-reference (url home-page)
+                           (commit (string-append "v" version))))
        (file-name (string-append name "-" version ".tar.gz"))
        (sha256
         (base32
-         "16qqa32ys3gvxf9x1va2cnjcmw1zvbwgc16pqasgrf4mh7qwsd9b"))))
+         "1wi70r56pd5z0x4dp4m58p9asq03j74kdm4fi9vai83vsl2z9amq"))))
     (build-system emacs-build-system)
     (propagated-inputs
      `(("emacs-xml-rpc" ,emacs-xml-rpc)))
-    (home-page "https://github.com/alezost/debpaste.el")
-    (synopsis "This package provides an interface for receiving, posting and
-deleting pastes from the Debian Pastezone.")
-    (description "Debpaste is an Emacs interface for the Debian Pastezone.
-It provides receiving, posting and deleting pastes using XML-RPC.")
+    (synopsis "Manipulate pastes from the Debian Pastezone")
+    (description "Debpaste is an Emacs interface for the Debian Pastezone,
+allowing you to receive, post, and delete pastes.  It communicates with the
+server using XML-RPC.")
     (license license:gpl3+)))
 
 (define-public emacs-xml-rpc