diff mbox series

[bug#35890,4/4] gnu: python-hdf4: Remove check-phase argument.

Message ID 87zhnbpee0.fsf@posteo.net
State Accepted
Headers show
Series [bug#35891,1/4] gnu: python-psutil: Update to 5.6.2. | expand

Commit Message

Brett Gilio May 25, 2019, 12:27 a.m. UTC

Comments

Marius Bakke May 26, 2019, 8:28 a.m. UTC | #1
Brett Gilio <brettg@posteo.net> writes:

> From 74c956284d5ff7b20e12ed4315404697320dc809 Mon Sep 17 00:00:00 2001
> From: Brett Gilio <brettg@posteo.net>
> Date: Fri, 24 May 2019 19:11:00 -0500
> Subject: [PATCH 4/4] gnu: python-hdf4: Remove check-phase argument.
>
> * gnu/packages/python-xyz.scm (python-hdf4): Update to .
> ---
>  gnu/packages/python-xyz.scm | 15 ---------------
>  1 file changed, 15 deletions(-)
>
> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
> index 54cc0c2b27..43287d212e 100644
> --- a/gnu/packages/python-xyz.scm
> +++ b/gnu/packages/python-xyz.scm
> @@ -385,21 +385,6 @@ and verifies that it matches the intended target hostname.")
>      `(("hdf4" ,hdf4)
>        ("libjpeg" ,libjpeg)
>        ("zlib" ,zlib)))
> -   (arguments
> -    `(#:phases
> -      (modify-phases %standard-phases
> -        (replace 'check
> -          (lambda _
> -            ;; The 'runexamples' script sets PYTHONPATH to CWD, then goes
> -            ;; on to import numpy. Somehow this works on their CI system.
> -            ;; Let's just manage PYTHONPATH here instead.
> -            (substitute* "runexamples.sh"
> -              (("export PYTHONPATH=.*") ""))
> -            (setenv "PYTHONPATH"
> -                    (string-append (getcwd) ":"
> -                                   (getenv "PYTHONPATH")))
> -            (invoke "./runexamples.sh")
> -            (invoke "nosetests" "-v"))))))
>     (home-page "https://github.com/fhs/python-hdf4")
>     (synopsis "Python interface to the NCSA HDF4 library")
>     (description

While this makes the build succeed, the 'check' phase is now moot.  It
appears to simply build the library for a second time, and then prints
'Ran 0 tests in N seconds...'.

Can you look into what happened to the tests between version 0.9.0 and
0.9.2?
Ricardo Wurmus May 26, 2019, 10:53 a.m. UTC | #2
Brett Gilio <brettg@posteo.net> writes:

> From 74c956284d5ff7b20e12ed4315404697320dc809 Mon Sep 17 00:00:00 2001
> From: Brett Gilio <brettg@posteo.net>
> Date: Fri, 24 May 2019 19:11:00 -0500
> Subject: [PATCH 4/4] gnu: python-hdf4: Remove check-phase argument.
>
> * gnu/packages/python-xyz.scm (python-hdf4): Update to .

I guess you’re using the yasnippets for Emacs :)

It’s fine to do this in the same commit as the upgrade, but as Marius
wrote the tests should actually be run.
Ludovic Courtès July 2, 2019, 3:22 p.m. UTC | #3
Hello Brett,

Marius Bakke <mbakke@fastmail.com> skribis:

> Brett Gilio <brettg@posteo.net> writes:
>
>> From 74c956284d5ff7b20e12ed4315404697320dc809 Mon Sep 17 00:00:00 2001
>> From: Brett Gilio <brettg@posteo.net>
>> Date: Fri, 24 May 2019 19:11:00 -0500
>> Subject: [PATCH 4/4] gnu: python-hdf4: Remove check-phase argument.
>>
>> * gnu/packages/python-xyz.scm (python-hdf4): Update to .
>> ---
>>  gnu/packages/python-xyz.scm | 15 ---------------
>>  1 file changed, 15 deletions(-)
>>
>> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
>> index 54cc0c2b27..43287d212e 100644
>> --- a/gnu/packages/python-xyz.scm
>> +++ b/gnu/packages/python-xyz.scm
>> @@ -385,21 +385,6 @@ and verifies that it matches the intended target hostname.")
>>      `(("hdf4" ,hdf4)
>>        ("libjpeg" ,libjpeg)
>>        ("zlib" ,zlib)))
>> -   (arguments
>> -    `(#:phases
>> -      (modify-phases %standard-phases
>> -        (replace 'check
>> -          (lambda _
>> -            ;; The 'runexamples' script sets PYTHONPATH to CWD, then goes
>> -            ;; on to import numpy. Somehow this works on their CI system.
>> -            ;; Let's just manage PYTHONPATH here instead.
>> -            (substitute* "runexamples.sh"
>> -              (("export PYTHONPATH=.*") ""))
>> -            (setenv "PYTHONPATH"
>> -                    (string-append (getcwd) ":"
>> -                                   (getenv "PYTHONPATH")))
>> -            (invoke "./runexamples.sh")
>> -            (invoke "nosetests" "-v"))))))
>>     (home-page "https://github.com/fhs/python-hdf4")
>>     (synopsis "Python interface to the NCSA HDF4 library")
>>     (description
>
> While this makes the build succeed, the 'check' phase is now moot.  It
> appears to simply build the library for a second time, and then prints
> 'Ran 0 tests in N seconds...'.
>
> Can you look into what happened to the tests between version 0.9.0 and
> 0.9.2?

Any update on this?

Ludo’.
Maxim Cournoyer July 16, 2022, 3:57 a.m. UTC | #4
Hi,

Ludovic Courtès <ludo@gnu.org> writes:

> Hello Brett,
>
> Marius Bakke <mbakke@fastmail.com> skribis:
>
>> Brett Gilio <brettg@posteo.net> writes:
>>
>>> From 74c956284d5ff7b20e12ed4315404697320dc809 Mon Sep 17 00:00:00 2001
>>> From: Brett Gilio <brettg@posteo.net>
>>> Date: Fri, 24 May 2019 19:11:00 -0500
>>> Subject: [PATCH 4/4] gnu: python-hdf4: Remove check-phase argument.
>>>
>>> * gnu/packages/python-xyz.scm (python-hdf4): Update to .
>>> ---
>>>  gnu/packages/python-xyz.scm | 15 ---------------
>>>  1 file changed, 15 deletions(-)
>>>
>>> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
>>> index 54cc0c2b27..43287d212e 100644
>>> --- a/gnu/packages/python-xyz.scm
>>> +++ b/gnu/packages/python-xyz.scm
>>> @@ -385,21 +385,6 @@ and verifies that it matches the intended target hostname.")
>>>      `(("hdf4" ,hdf4)
>>>        ("libjpeg" ,libjpeg)
>>>        ("zlib" ,zlib)))
>>> -   (arguments
>>> -    `(#:phases
>>> -      (modify-phases %standard-phases
>>> -        (replace 'check
>>> -          (lambda _
>>> -            ;; The 'runexamples' script sets PYTHONPATH to CWD, then goes
>>> -            ;; on to import numpy. Somehow this works on their CI system.
>>> -            ;; Let's just manage PYTHONPATH here instead.
>>> -            (substitute* "runexamples.sh"
>>> -              (("export PYTHONPATH=.*") ""))
>>> -            (setenv "PYTHONPATH"
>>> -                    (string-append (getcwd) ":"
>>> -                                   (getenv "PYTHONPATH")))
>>> -            (invoke "./runexamples.sh")
>>> -            (invoke "nosetests" "-v"))))))
>>>     (home-page "https://github.com/fhs/python-hdf4")
>>>     (synopsis "Python interface to the NCSA HDF4 library")
>>>     (description
>>
>> While this makes the build succeed, the 'check' phase is now moot.  It
>> appears to simply build the library for a second time, and then prints
>> 'Ran 0 tests in N seconds...'.
>>
>> Can you look into what happened to the tests between version 0.9.0 and
>> 0.9.2?
>
> Any update on this?

No update in 3 years; closing.

Maxim
diff mbox series

Patch

From 74c956284d5ff7b20e12ed4315404697320dc809 Mon Sep 17 00:00:00 2001
From: Brett Gilio <brettg@posteo.net>
Date: Fri, 24 May 2019 19:11:00 -0500
Subject: [PATCH 4/4] gnu: python-hdf4: Remove check-phase argument.

* gnu/packages/python-xyz.scm (python-hdf4): Update to .
---
 gnu/packages/python-xyz.scm | 15 ---------------
 1 file changed, 15 deletions(-)

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 54cc0c2b27..43287d212e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -385,21 +385,6 @@  and verifies that it matches the intended target hostname.")
     `(("hdf4" ,hdf4)
       ("libjpeg" ,libjpeg)
       ("zlib" ,zlib)))
-   (arguments
-    `(#:phases
-      (modify-phases %standard-phases
-        (replace 'check
-          (lambda _
-            ;; The 'runexamples' script sets PYTHONPATH to CWD, then goes
-            ;; on to import numpy. Somehow this works on their CI system.
-            ;; Let's just manage PYTHONPATH here instead.
-            (substitute* "runexamples.sh"
-              (("export PYTHONPATH=.*") ""))
-            (setenv "PYTHONPATH"
-                    (string-append (getcwd) ":"
-                                   (getenv "PYTHONPATH")))
-            (invoke "./runexamples.sh")
-            (invoke "nosetests" "-v"))))))
    (home-page "https://github.com/fhs/python-hdf4")
    (synopsis "Python interface to the NCSA HDF4 library")
    (description
-- 
2.21.0