diff mbox

[bug#39882,0/1] Add kexec-tools.

Message ID 87zhcx4o7z.fsf@nckx
State Accepted
Headers show

Commit Message

ashish.is--- via Guix-patches" via March 3, 2020, 12:28 p.m. UTC
Chris,

Chris Marusich 写道:
> I was kind of surprised to find that kexec-tools was not already
> packaged.  Is there a reason why it hasn't been packaged, or am 
> I just
> the first one to try packaging it?

I was also surprised, having installed kexec-tools on Guix before 
;-)

Turns out I never upstreamed it.  There are probably 5 other 
kexec-tools patches somewhere.  Oh well.

Your patch looks good to me.  I prefer the home page below over a 
directory listing.  Feel free to crib what you like.

Your synopsis/description imply that it's boot-Linux-only.  I 
don't think that's the case, but haven't tried others in practice.

Thanks!

T G-R


commit 69a6d90a988f86e556b2fb39092755f88eb9d323
Author: Tobias Geerinckx-Rice <me@tobias.gr>
Date:   Thu Feb 8 16:13:57 2018 +0100

    gnu: Add kexec-tools.
    
    * gnu/packages/linux.scm (kexec-tools): New public variable.

into memory and
+reboot directly into it using the @code{kexec} system call, 
bypassing the normal
+boot process.  @dfn{Kexec} is the mechanism by which both Linux 
and Xen kernels
+can support fast soft reboots and kernel crash dump analysis.")
+    (license license:gpl2)))

Comments

Christopher Marusich March 3, 2020, 1:08 p.m. UTC | #1
Hi Tobias,

Sounds good.  I've gone ahead and committed this in commit
dedbdacf275cb7871c7336bd7a27ceb609b15113 with a few little changes, per
your suggestions.

Tobias Geerinckx-Rice <me@tobias.gr> writes:

> I was also surprised, having installed kexec-tools on Guix before ;-)
>
> Turns out I never upstreamed it.  There are probably 5 other
> kexec-tools patches somewhere.  Oh well.

Glad to know I wasn't missing something :-)

> Your patch looks good to me.  I prefer the home page below over a
> directory listing.  Feel free to crib what you like.
>
> Your synopsis/description imply that it's boot-Linux-only.  I don't
> think that's the case, but haven't tried others in practice.

You're probably right.  I've removed the Linux-specific wording.

> +     (origin
> +       (method url-fetch)
> +       (uri (string-append
> "mirror://kernel.org/pub/linux/utils/kernel/kexec/"
> +                           "kexec-tools-" version ".tar.xz"))

I didn't know we had mirror config for kernel.org.  I've switched to
using that in the latest patch.

> +       (sha256
> +        (base32
> "0ra8ph9m1dckqaikfnbsh408fp2w9k49fkl425fl2hvhwsm14xk6"))))
> +    (build-system gnu-build-system)
> +    (home-page "https://projects.horms.net/projects/kexec/")

Yes, this home page is better.  I'll use it!

> +    (synopsis "Linux tools to directly execute different kernels")

I've changed my synopsis to be more like yours.
diff mbox

Patch

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 303a85c7fd..1ebc8b1744 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -4632,3 +4632,24 @@  text-mode or graphical applications that 
don't use a display server.
 Also included is @command{fbgrab}, a wrapper around 
 @command{fbcat} that
 emulates the behaviour of Gunnar Monell's older fbgrab utility.")
     (license license:gpl2)))
+
+(define-public kexec-tools
+  (package
+    (name "kexec-tools")
+    (version "2.0.15")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append 
"mirror://kernel.org/pub/linux/utils/kernel/kexec/"
+                           "kexec-tools-" version ".tar.xz"))
+       (sha256
+        (base32 
"0ra8ph9m1dckqaikfnbsh408fp2w9k49fkl425fl2hvhwsm14xk6"))))
+    (build-system gnu-build-system)
+    (home-page "https://projects.horms.net/projects/kexec/")
+    (synopsis "Linux tools to directly execute different 
kernels")
+    (description "This package provides tools to load a kernel