diff mbox series

[bug#41460] gnu: Add python-pyfiglet

Message ID 87zh9lbss8.fsf@alice.lan
State Accepted
Headers show
Series [bug#41460] gnu: Add python-pyfiglet | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Edouard Klein June 2, 2020, 11:39 a.m. UTC
* gnu/packages/python-xyz.scm (python-pyfiglet): New variable.
---
 gnu/packages/python-xyz.scm | 18 ++++++++++++++++++
 1 file changed, 18 insertions(+)

Comments

Marius Bakke June 22, 2020, 7:44 p.m. UTC | #1
Edouard Klein <edk@beaver-labs.com> writes:

> * gnu/packages/python-xyz.scm (python-pyfiglet): New variable.

Applied, thanks!
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 6aa666430a..3ecfaab081 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10087,6 +10087,24 @@  interface to the Amazon Web Services (AWS) API.")
 (define-public python2-botocore
   (package-with-python2 python-botocore))
 
+(define-public python-pyfiglet
+  (package
+    (name "python-pyfiglet")
+    (version "0.8.post1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "pyfiglet" version))
+       (sha256
+        (base32
+         "0f9n2076ga2ccsg174k2d7n0z4d44ml96yzc72s6g4nhalbk5hn6"))))
+    (build-system python-build-system)
+    (home-page "https://github.com/pwaller/pyfiglet")
+    (synopsis "Draw ASCII art big letters in pure-python")
+    (description "This module lets you draw large letter from ordinary characters
+ in pure Python.")
+    (license license:expat)))
+
 (define-public python-xdo
   (package
     (name "python-xdo")