diff mbox series

[bug#42021] Fix flatpak configure option

Message ID 87zh8tyel5.fsf@terpri.org
State Accepted
Headers show
Series [bug#42021] Fix flatpak configure option | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Robin Templeton June 23, 2020, 3:41 p.m. UTC
Currently, running an installed flatpak program (e.g. "flatpak run
com.github.micahflee.torbrowser-launcher") results in this error:

"bwrap: execvp xdg-dbus-proxy: No such file or directory"

Setting the full xdg-dbug-proxy path during configuration prevents this
error and allows flatpak programs to be run normally.

From 401c68d4d1581bc93eb67ff1f4feb21014dc513f Mon Sep 17 00:00:00 2001
From: Robin Templeton <robin@terpri.org>
Date: Tue, 23 Jun 2020 11:17:07 -0400
Subject: [PATCH] gnu: flatpak: Fix xdg-dbus-proxy configure flag.

* gnu/packages/package-management.scm (flatpak) [arguments]: Pass the full
"xdg-dbus-proxy" program path to the "--with-system-dbus-proxy" configure
flag.
---
 gnu/packages/package-management.scm | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

Comments

Ludovic Courtès June 23, 2020, 9:39 p.m. UTC | #1
Hi Robin,

Robin Templeton <robin@terpri.org> skribis:

>>From 401c68d4d1581bc93eb67ff1f4feb21014dc513f Mon Sep 17 00:00:00 2001
> From: Robin Templeton <robin@terpri.org>
> Date: Tue, 23 Jun 2020 11:17:07 -0400
> Subject: [PATCH] gnu: flatpak: Fix xdg-dbus-proxy configure flag.
>
> * gnu/packages/package-management.scm (flatpak) [arguments]: Pass the full
> "xdg-dbus-proxy" program path to the "--with-system-dbus-proxy" configure
> flag.

Good catch, applied!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 2cd7886011..44321240e9 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -1152,7 +1152,9 @@  the boot loader configuration.")
        (string-append "--with-system-bubblewrap="
                       (assoc-ref %build-inputs "bubblewrap")
                       "/bin/bwrap")
-       "--with-system-dbus-proxy")
+       (string-append "--with-system-dbus-proxy="
+                      (assoc-ref %build-inputs "xdg-dbus-proxy")
+                      "/bin/xdg-dbus-proxy"))
       #:phases
       (modify-phases %standard-phases
         (add-after 'unpack 'fix-tests