diff mbox series

[bug#43551] Add package emacs-quickrun

Message ID 87zh5jxkt6.fsf@posteo.net
State Accepted
Headers show
Series [bug#43551] Add package emacs-quickrun | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Niklas Eklund Sept. 21, 2020, 2:32 p.m. UTC

Comments

Nicolas Goaziou Sept. 22, 2020, 9:07 a.m. UTC | #1
Hello,

Niklas Eklund <niklas.eklund@posteo.net> writes:

> Subject: [PATCH] gnu: Add emacs-quickrun.

Thank you.

> +(define-public emacs-quickrun
> +  (let ((commit "0133cac651918071a824e85b55e10d44f32a1979")
> +        (revision "0"))

I don't think there is any reason to use a commit directly, since this
one matches a release.

> +    (package
> +      (name "emacs-quickrun")
> +      (version (git-version "2.3.1" revision commit))

    (version "2.3.1")

is enough per above.

> +      (source
> +       (origin
> +         (method git-fetch)
> +         (uri (git-reference
> +               (url "https://github.com/emacsorphanage/quickrun")
> +               (commit commit)))

    (commit version)

> +         (sha256
> +          (base32
> +           "0a1n2v09h0n7d9p2izflqqang4ny0b46dlqvmxvkkik4bb6f4wcz"))

Please move the hash string on the same line as base32.

> +         (file-name (git-file-name name version))))
> +      (build-system emacs-build-system)
> +      (home-page
> +       "https://github.com/emacsorphanage/quickrun")

Please move the URL on the same line as home-page

> +      (synopsis "Run commands quickly")
> +      (description
> +       "This package evaluates the content of a buffer, or region and displays
> +the result.  It is similar to executable-interpret, but provides more
> +convenient commands.  Quickrun execute not only script languages(Perl, Ruby,

Quickrun executes ... languages (Perl

> +Python etc), but also compiling languages(C, C++, Go, Java etc) and
> markup

Mind the missing space here, too.

Could you send an updated patch?

Regards,
Niklas Eklund Sept. 22, 2020, 9:33 a.m. UTC | #2
Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:

> Could you send an updated patch?

> Regards,
> -- 
> Nicolas Goaziou

Hi Nicolas,

Thanks for your review. I will address your comments and create an
updated patch. It's my first time contributing to guix, so I hope I am
sending this message correctly :)

// Niklas
diff mbox series

Patch

From ec5a8a6d3ded11f48d12e66018790b2d03bbd624 Mon Sep 17 00:00:00 2001
From: Niklas Eklund <niklas.eklund@posteo.net>
Date: Mon, 21 Sep 2020 12:44:55 +0200
Subject: [PATCH] gnu: Add emacs-quickrun.

* gnu/packages/emacs-xyz.scm (emacs-quickrun): New variable.
---
 gnu/packages/emacs-xyz.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 4634836b89..8aa4304312 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -78,6 +78,7 @@ 
 ;;; Copyright © 2020 Eric Bavier <bavier@posteo.net>
 ;;; Copyright © 2020 Morgan Smith <Morgan.J.Smith@outlook.com>
 ;;; Copyright © 2020 Peng Mei Yu <i@pengmeiyu.com>
+;;; Copyright © 2020 Niklas Eklund <niklas.eklund@posteo.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -24647,3 +24648,31 @@  publically-accessible HTTP server.")
 label references and citations in LaTeX.  It is based on RefTeX, which is
 included with Emacs.")
     (license license:gpl3+)))
+
+(define-public emacs-quickrun
+  (let ((commit "0133cac651918071a824e85b55e10d44f32a1979")
+        (revision "0"))
+    (package
+      (name "emacs-quickrun")
+      (version (git-version "2.3.1" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/emacsorphanage/quickrun")
+               (commit commit)))
+         (sha256
+          (base32
+           "0a1n2v09h0n7d9p2izflqqang4ny0b46dlqvmxvkkik4bb6f4wcz"))
+         (file-name (git-file-name name version))))
+      (build-system emacs-build-system)
+      (home-page
+       "https://github.com/emacsorphanage/quickrun")
+      (synopsis "Run commands quickly")
+      (description
+       "This package evaluates the content of a buffer, or region and displays
+the result.  It is similar to executable-interpret, but provides more
+convenient commands.  Quickrun execute not only script languages(Perl, Ruby,
+Python etc), but also compiling languages(C, C++, Go, Java etc) and markup
+languages.")
+      (license license:gpl3+))))
-- 
2.28.0