diff mbox series

[bug#44515] gnu: xmlstarlet: Install symlink to xmlstarlet binary.

Message ID 87zh3sumjy.fsf@gmx.com
State Accepted
Headers show
Series [bug#44515] gnu: xmlstarlet: Install symlink to xmlstarlet binary. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Pierre Langlois Nov. 8, 2020, 11:15 a.m. UTC
Hello Guix!

I recently encountered a small script incompatibility between Guix and
other distros (Arch, Fedora, Debian) because the `xml' binary is often
either moved or symlinked to `xmlstarlet'.

So here's a patch that adds the symlink, is that OK to commit?

Thanks,
Pierre

Comments

Ludovic Courtès Nov. 18, 2020, 10:42 p.m. UTC | #1
Hi,

Pierre Langlois <pierre.langlois@gmx.com> skribis:

> I recently encountered a small script incompatibility between Guix and
> other distros (Arch, Fedora, Debian) because the `xml' binary is often
> either moved or symlinked to `xmlstarlet'.
>
> So here's a patch that adds the symlink, is that OK to commit?

Sure!  Maybe add a comment above stating that several other distros do
that.

>>From a285bc89eb37a5aa56d444c195d9ef013a30aeec Mon Sep 17 00:00:00 2001
> From: Pierre Langlois <pierre.langlois@gmx.com>
> Date: Fri, 30 Oct 2020 11:57:35 +0000
> Subject: [PATCH] gnu: xmlstarlet: Install symlink to xmlstarlet binary.
>
> * gnu/packages/xml.scm (xmlstarlet)[arguments]: Add 'symlink-xmlstarlet
> phase.

[...]

> +       (add-after 'install 'symlink-xmlstarlet
> +         (lambda* (#:key outputs #:allow-other-keys)
> +           (let* ((out (assoc-ref outputs "out"))
> +                  (bin (string-append out "/bin")))
> +             (symlink (string-append bin "/xml")
                         ^
"xml" is enough.

Thanks,
Ludo’.
Pierre Langlois Nov. 19, 2020, 8:03 p.m. UTC | #2
Hi Ludo'

Ludovic Courtès writes:

> Hi,
>
> Pierre Langlois <pierre.langlois@gmx.com> skribis:
>
>> I recently encountered a small script incompatibility between Guix and
>> other distros (Arch, Fedora, Debian) because the `xml' binary is often
>> either moved or symlinked to `xmlstarlet'.
>>
>> So here's a patch that adds the symlink, is that OK to commit?
>
> Sure!  Maybe add a comment above stating that several other distros do
> that.
>
>>>From a285bc89eb37a5aa56d444c195d9ef013a30aeec Mon Sep 17 00:00:00 2001
>> From: Pierre Langlois <pierre.langlois@gmx.com>
>> Date: Fri, 30 Oct 2020 11:57:35 +0000
>> Subject: [PATCH] gnu: xmlstarlet: Install symlink to xmlstarlet binary.
>>
>> * gnu/packages/xml.scm (xmlstarlet)[arguments]: Add 'symlink-xmlstarlet
>> phase.
>
> [...]
>
>> +       (add-after 'install 'symlink-xmlstarlet
>> +         (lambda* (#:key outputs #:allow-other-keys)
>> +           (let* ((out (assoc-ref outputs "out"))
>> +                  (bin (string-append out "/bin")))
>> +             (symlink (string-append bin "/xml")
>                          ^
> "xml" is enough.

Oh cool, thanks for the review! Pushed with
b04198a1477f9d685d674a1dcc81b79b530fc409.

Thanks,
Pierre
diff mbox series

Patch

From a285bc89eb37a5aa56d444c195d9ef013a30aeec Mon Sep 17 00:00:00 2001
From: Pierre Langlois <pierre.langlois@gmx.com>
Date: Fri, 30 Oct 2020 11:57:35 +0000
Subject: [PATCH] gnu: xmlstarlet: Install symlink to xmlstarlet binary.

* gnu/packages/xml.scm (xmlstarlet)[arguments]: Add 'symlink-xmlstarlet
phase.
---
 gnu/packages/xml.scm | 10 +++++++++-
 1 file changed, 9 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 97d42b2ae2..cd99cd4bcc 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -25,6 +25,7 @@ 
 ;;; Copyright © 2020 Paul Garlick <pgarlick@tourbillion-technology.com>
 ;;; Copyright © 2020 Edouard Klein <edk@beaver-labs.com>
 ;;; Copyright © 2020 Brett Gilio <brettg@gnu.org>
+;;; Copyright © 2020 Pierre Langlois <pierre.langlois@gmx.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1260,7 +1261,14 @@  C++ programming language.")
            (substitute* "Makefile"
              (("^examples/schema1\\\\") "\\")
              (("^examples/valid1\\\\") "\\"))
-           #t)))))
+           #t))
+       (add-after 'install 'symlink-xmlstarlet
+         (lambda* (#:key outputs #:allow-other-keys)
+           (let* ((out (assoc-ref outputs "out"))
+                  (bin (string-append out "/bin")))
+             (symlink (string-append bin "/xml")
+                      (string-append bin "/xmlstarlet"))
+             #t))))))
    (inputs
     `(("libxslt" ,libxslt)
       ("libxml2" ,libxml2)))
-- 
2.29.2