diff mbox series

[bug#46598] gnu: Add vitetris.

Message ID 87zh01azs1.fsf@xsteve.at
State Accepted
Headers show
Series [bug#46598] gnu: Add vitetris. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Stefan Reichör Feb. 18, 2021, 8:26 p.m. UTC
Hi Nicolas,

thanks for the detailed review of my patch.

I didn't think that I am able to produce a patch with that many little
shortcomings ;-)

Your help is highly appreciated!

> Hello,
>
> Stefan Reichör <stefan@xsteve.at> writes:
>
>> * gnu/packages/games.scm (vitetris): New variable.
>
> Thank you! Some comments follow.
>
>
>> +    (version "v0.59.1")
>
> You're mixing the version and the tag name. The version should be
> "0.59.1"...
>
>> +    (source
>> +     (origin
>> +       (method git-fetch)
>> +       (uri (git-reference
>> +             (url "https://github.com/vicgeralds/vitetris")
>> +             (commit version)))
>
> ... and the commit should be (string-append "v" version).
>
>> +                      ;; src/src-conf.mk must be writable for the build step
>> +                      (chmod "src/src-conf.mk" #o666)
>
> I suggest (make-file-writeable "src/src-conf.mk")
>
>> +                      #t)))
>
> You can omit it.
>
>> +       #:tests? #f   ; no test
>> +       #:make-flags
>> +       (list ,(string-append "CC=" (cc-for-target))
>> +             (string-append "DESTDIR=" (assoc-ref %outputs "out")))))
>
> There is an issue here.  The install script does not install executable
> in %out/bin, but in %out/usr/local/bin.
>
>> +    (home-page "http://victornils.net/tetris/")
>> +    (synopsis "Terminal-based tetris clone")
>
> tetris -> Tetris
>
>> +    (description "Classic multiplayer tetris for the terminal.")
>
> I suggest:
>
>   Vitetris is a classic multiplayer Tetris clone for the terminal.
>
>
> Could you send an updated patch?

Of course - I hope that I have addressed all the issues.

> Regards,

Comments

Nicolas Goaziou Feb. 18, 2021, 9:44 p.m. UTC | #1
Stefan Reichör <stefan@xsteve.at> writes:

> I didn't think that I am able to produce a patch with that many little
> shortcomings ;-)

Heh :)

> Of course - I hope that I have addressed all the issues.

Perfect! Applied. Thank you!

Regards,
diff mbox series

Patch

gnu: Add vitetris.

From: Stefan Reichör <stefan@xsteve.at>

* gnu/packages/games.scm (vitetris): New variable.
---
 gnu/packages/games.scm |   34 ++++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index d8c98a9a2f..bab2714c0d 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -57,6 +57,7 @@ 
 ;;; Copyright © 2020 Lu hux <luhux@outlook.com>
 ;;; Copyright © 2020 Tomás Ortín Fernández <tomasortin@mailbox.org>
 ;;; Copyright © 2021 Olivier Rojon <o.rojon@posteo.net>
+;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -545,6 +546,39 @@  Playing bastet can be a painful experience, especially if you usually make
 canyons and wait for the long I-shaped block to clear four rows at a time.")
     (license license:gpl3+)))
 
+(define-public vitetris
+  (package
+    (name "vitetris")
+    (version "0.59.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/vicgeralds/vitetris")
+             (commit (string-append "v" version))))
+       (sha256
+        (base32 "1ah1c5g7abksif0n8v5rb7r4pn2az20c3mkp4ak13vgs23ddmds5"))
+       (file-name (git-file-name name version))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:phases (modify-phases %standard-phases
+                  (replace 'configure
+                    (lambda _
+                      ;; the non standard configure script does not accept
+                      ;; standard parameters -> invoke configure by hand
+                      (invoke "./configure" "prefix=")
+                      ;; src/src-conf.mk must be writable for the build step
+                      (make-file-writable "src/src-conf.mk"))))
+       #:tests? #f   ; no test
+       #:make-flags
+       (list ,(string-append "CC=" (cc-for-target))
+             (string-append "DESTDIR=" (assoc-ref %outputs "out")))))
+    (home-page "http://victornils.net/tetris/")
+    (synopsis "Terminal-based Tetris clone")
+    (description "Vitetris is a classic multiplayer Tetris clone for the
+terminal.")
+    (license license:bsd-2)))
+
 (define-public blobwars
   (package
     (name "blobwars")