diff mbox series

[bug#53733] gnu: Add emacs-spell-fu

Message ID 87zgn5391b.fsf@posteo.net
State Accepted
Headers show
Series [bug#53733] gnu: Add emacs-spell-fu | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Niklas Eklund Feb. 5, 2022, 10:25 a.m. UTC
Fix commit message to actually refer to the correct package.

/Niklas

Comments

Ludovic Courtès March 3, 2022, 10:50 p.m. UTC | #1
Hi,

Niklas Eklund <niklas.eklund@posteo.net> skribis:

>>From f4eacdbecec68d4ea100e92cd5e0283ac83a5baf Mon Sep 17 00:00:00 2001
> From: Niklas Eklund <niklas.eklund@posteo.net>
> Date: Wed, 2 Feb 2022 19:49:46 +0100
> Subject: [PATCH] gnu: Add emacs-spell-fu.
>
> * gnu/packages/emacs-xyz.scm (emacs-spell-fu): New variable.

Applied, thanks!

Ludo’.
diff mbox series

Patch

From f4eacdbecec68d4ea100e92cd5e0283ac83a5baf Mon Sep 17 00:00:00 2001
From: Niklas Eklund <niklas.eklund@posteo.net>
Date: Wed, 2 Feb 2022 19:49:46 +0100
Subject: [PATCH] gnu: Add emacs-spell-fu.

* gnu/packages/emacs-xyz.scm (emacs-spell-fu): New variable.
---
 gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index e2eff4a872..681e0e2fc7 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -26451,6 +26451,30 @@  (define-public emacs-flyspell-correct
 Helm and Ivy.")
     (license license:gpl3+)))
 
+(define-public emacs-spell-fu
+  ;; There are no tagged releases upstream on gitlab, instead we are using the
+  ;; most recent commit.
+  (let ((commit "50be652a6ec8590c3098f46094a92213623349c1") (revision "0"))
+    (package
+      (name "emacs-spell-fu")
+      (version (git-version "0.3" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://gitlab.com/ideasman42/emacs-spell-fu")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "0n7qwnirvkh2aprb7l1wj9rywdsn33a7s32716m3afcvy7z9pyh4"))))
+      (build-system emacs-build-system)
+      (home-page "https://gitlab.com/ideasman42/emacs-spell-fu")
+      (synopsis "Fast highlighting of misspelled words")
+      (description
+       "This is a light weight spell checker for Emacs,
+that runs from the syntax highlighter without starting external processes.")
+      (license license:gpl3+))))
+
 (define-public emacs-org-emms
   (let ((commit "07a8917f3d628c32e5de1dbd118ac08203772533")
         (revision "1"))
-- 
2.34.0