diff mbox series

bug#58045: [PATCH] gnu: Add libpatch.

Message ID 87zgemqmyt.fsf@gnu.org
State Accepted
Headers show
Series bug#58045: [PATCH] gnu: Add libpatch. | expand

Commit Message

Mathieu Othacehe Sept. 26, 2022, 1:33 p.m. UTC
> * gnu/packages/instrumentation.scm (libpatch): New variable.

Applied with the following diff:

--8<---------------cut here---------------start------------->8---
--8<---------------cut here---------------end--------------->8---

Thanks,

Mathieu
diff mbox series

Patch

diff --git a/gnu/packages/instrumentation.scm b/gnu/packages/instrumentation.scm
index b611f2b141..3d6b6fab38 100644
--- a/gnu/packages/instrumentation.scm
+++ b/gnu/packages/instrumentation.scm
@@ -233,28 +233,25 @@  (define-public libpatch
             (or
              (%current-target-system)
              (%current-system))))))))
+    ;;; Add lttng-ust to the inputs if you want tracepoints within libpatch
+    ;;; for debugging.
     (inputs
      (list capstone
            elfutils
-           ;; Uncomment the following if you want tracepoints within libpatch
-           ;; for debugging.
-           ;;
-           ;; lttng-ust
            libunwind
            liburcu))
     (native-inputs
      (list coreutils
            ;; test-ftrace.scm
            (list coreutils "debug")
+           (list guile-3.0 "debug")
+           (list gnu-make "debug")
+
            ;; For eu-nm in test-ftrace.scm.
            (list elfutils "bin")
-           ;; Put Guile in your profile if you want to use the bindings.
+
            guile-3.0
-           ;; test-ftrace.scm
-           (list guile-3.0 "debug")
            gnu-make
-           ;; test-ftrace.scm
-           (list gnu-make "debug")
            pkg-config
            ;; zlib is required by libdw.  This can be removed if zlib is put
            ;; as a propagated-input of elfutils.