diff mbox series

[bug#65453] gnu: sbcl-njson: Update to 1.1.1.

Message ID 87zg2jcmxd.fsf@aartaka.me
State New
Headers show
Series [bug#65453] gnu: sbcl-njson: Update to 1.1.1. | expand

Commit Message

Artyom Bologov Aug. 22, 2023, 11:52 a.m. UTC
Hello Guix,

Find the patch updating sbcl-njson to 1.1.1 attached to this message.
Thanks,
--
Artyom Bologov.

Comments

Mathieu Othacehe Oct. 5, 2023, 3:17 p.m. UTC | #1
Hello,

> * gnu/packages/lisp-xyz.scm (sbcl-json): Update to 1.1.1.

We already have the 1.2.1 revision upstream, closing.

Mathieu
diff mbox series

Patch

From fd6583d95f4b4d4b6238c303961c87807edb69ed Mon Sep 17 00:00:00 2001
From: Artyom Bologov <mail@aartaka.me>
Date: Tue, 22 Aug 2023 15:48:34 +0400
Subject: [PATCH] gnu: sbcl-njson: Update to 1.1.1.

* gnu/packages/lisp-xyz.scm (sbcl-json): Update to 1.1.1.
---
 gnu/packages/lisp-xyz.scm | 20 +++++++++++---------
 1 file changed, 11 insertions(+), 9 deletions(-)

diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index d62122f408..4ea4de5264 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -26600,7 +26600,7 @@  (define-public ecl-nkeymaps
 (define-public sbcl-njson
   (package
     (name "sbcl-njson")
-    (version "1.1.0")
+    (version "1.1.1")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -26609,7 +26609,7 @@  (define-public sbcl-njson
               (file-name (git-file-name "cl-njson" version))
               (sha256
                (base32
-                "02m9l77am2rlkg83dyp3jvb76ifw1y84xh3wpz6cx7h2wkxkjnl5"))))
+                "0zdf6mlbpc2j95qm000ljf642af18sfz45yxh6rnxrbf8m4laxxa"))))
     (build-system asdf-build-system/sbcl)
     (inputs (list sbcl-cl-json sbcl-jzon))
     (native-inputs (list sbcl-lisp-unit2))
@@ -26622,23 +26622,25 @@  (define-public sbcl-njson
 and process JSON data, in the minimum keystrokes/minutes possible.
 
 NJSON is parser-independent, with existing Common Lisp JSON parsers being
-loadable as additional system.  @code{jzon} and @code{cl-json} backends are
-included by default, though.  Conveniences that NJSON provides are:
+loadable as additional system.  @code{jzon} is included by default, though.
+Conveniences that NJSON provides are:
 
 @itemize
 @item @code{encode} and @code{decode} as single entry points for JSON reading
 and writing, be it from streams/string/files, or from those.
 
-@item @code{jget}, @code{jrem}, @code{jtruep}, and their aliases to
-access/delete the decoded objects' properties and check their truth value
-without the need to worry about the low-level details of how these values are
-decoded.
+@item @code{jget}, @code{jcopy}, @code{jkeys}, and their aliases to
+manipulate the decoded objects' properties without the need to worry
+about the low-level details of how these values are decoded.
 
 @item @code{jif}, @code{jwhen}, @code{jor}, @code{jand}, and other macros
 mimicking Lisp ones, while using truth values of JSON-decoded data.
 
+@item @code{jbind} and @code{jmatch} macros to destructure and
+validate parsed JSON.
+
 @item @code{njson/aliases} package to nickname to @code{j} for all the
-forms conveniently accessible as @code{j:rem}, @code{j:get},
+forms conveniently accessible as @code{j:get}, @code{j:copy},
 @code{j:if} etc.
 
 @end itemize\n")
-- 
2.41.0